Jon Hill

Unable to remove packet decoder app rules

Blog Post created by Jon Hill Employee on Dec 14, 2016

Recently I had a customer who was unable to remove their Application rules from a packet decoder as part of removing the old IR 3.5 content.

 

If they tried to remove all the IR content rules at one time after they hit Apply the first time on the review screen where it would show what was being removed and what was to remain after the Apply button was not active.

 

If they tried to remove only a few rules at a time the Apply button on the review screen was active however upon reloading the Application rule tab all the deleted rules were back again.

 

To resolve the issue I made a backup of their Application rules and then navigated to the Explorer view of the packet decoder.

 

WARNING: This is a destructive clearing of all Application rules on the decoder. You will only want to do this if you are experiencing this issue or something similar. Make sure you have a back up copy of your current rule set.

 

 

Right click on application and click on Properties.

 

 

Select clear from the dropdown and then press send in the right hand corner of the Properties screen. You will see a success message in the information box. 

Outcomes