000036970 - Applying patch or upgrade fails after hardening RSA Authentication Manager appliance

Document created by RSA Customer Support Employee on Dec 19, 2018
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000036970
Applies ToRSA Product Set:  SecurID
RSA Product/Service Type:  Authentication Manager
RSA Version/Condition:  8.x
IssueAfter hardening the RSA Authentication Manager 8.x appliance, applying new patches or upgrades fails with the following error

INFO: Retrieving platform specification. Exception in thread "main" : exec returned: 1 
   at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:646) 
   at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:672) 
   at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:498) 
   at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291) 
   at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106) 
   at PatchUtils.execCommand(PatchUtils.groovy:575) 
   at PatchUtils$execCommand.callCurrent(Unknown Source) 
   at PatchUtils.setCurrentPlatformSpec(PatchUtils.groovy:887) 
   at PatchUtils$setCurrentPlatformSpec.call(Unknown Source) 
   at PatchUtils.initPatchProperties(PatchUtils.groovy:101) 
   at PatchUtils$initPatchProperties.call(Unknown Source) 
   at UpdateRollback$_preUpdate_closure1.doCall(UpdateRollback.groovy:14) 
   at UpdateRollback$_preUpdate_closure1.doCall(UpdateRollback.groovy) 
   at Utils.withArtifacts(Utils.groovy:48) at Utils$withArtifacts.call(Unknown Source) 
   at UpdateRollback.preUpdate(UpdateRollback.groovy:11)
   at com.rsa.plugins.install.GroovyInstallEngine.invokeScript(GroovyInstallEngine.groovy:68) 
   at com.rsa.plugins.install.GroovyInstallEngine$_runTask_closure2.doCall(GroovyInstallEngine.groovy:57) 
   at com.rsa.plugins.install.GroovyInstallEngine.runTask(GroovyInstallEngine.groovy:56) 
   at com.rsa.plugins.install.GroovyInstallEngine$_runTasks_closure3.doCall(GroovyInstallEngine.groovy:106) 
   at com.rsa.plugins.install.GroovyInstallEngine.runTasks(GroovyInstallEngine.groovy:105) 
   at com.rsa.plugins.install.GroovyInstallEngine$runTasks.call(Unknown Source) 
   at com.rsa.plugins.install.CommandLineInstallEngine.main(CommandLineInstallEngine.groovy:40) Configuration step UpdateRollback:preUpdate [FAILED] 
[ERROR] Error: Failed to invoke update engine: Failed to prepare the update. 
java.lang.Exception: Failed to prepare the update. 
   at com.rsa.am.updateengine.tasks.BaseUpdateEngineTask.doExecute(BaseUpdateEngineTask.java:56) 
   at com.rsa.am.updateengine.tasks.Task.execute(Task.java:136) 
   at com.rsa.am.updateengine.components.impl.TaskManagerImpl.doExecuteTask(TaskManagerImpl.java:86) 
   at com.rsa.am.updateengine.components.impl.TaskManagerImpl.execute(TaskManagerImpl.java:41) 
   at com.rsa.am.updateengine.components.impl.UpdateInstallerImpl.run(UpdateInstallerImpl.java:29) 
[INFO] Invoking config engine goal UpdateRollback:postUpdate 0 2018-11-05 10:11:26,680 
INFO: Arguments: [UpdateRollback.postUpdate] 2396 2018-11-05 10:11:29,076 
INFO: Will not attempt to fix line endings in patch source files 2444 2018-11-05 10:11:29,124 
INFO: Script source dir: /tmp/rsa_update/installer/config/src/scripts 2444 2018-11-05 10:11:29,124 
INFO: Patch Script source dir: /tmp/rsa_update/iso/rsa/scripts 2974 2018-11-05 10:11:29,654 
INFO: Reading configuration from Config.groovy 4326 2018-11-05 10:11:31,006 
INFO: Running task UpdateRollback.postUpdate 12155 2018-11-05 10:11:38,835 
INFO: Executing free 12611 2018-11-05 10:11:39,291 
INFO: output::: total used free shared buffers cached Mem: 8184876 7938344 246532 81356 39244 3050428 -/+ buffers/cache: 4848672 3336204 Swap: 4193276 26552 4166724 12611 2018-11-05 10:11:39,291 
INFO: else condition output::: total used free shared buffers cached Mem: 8184876 7938344 246532 81356 39244 3050428 -/+ buffers/cache: 4848672 3336204 Swap: 4193276 26552 4166724 12633 2018-11-05 10:11:39,313 
INFO: Total Memory: 8184876 KB 12660 2018-11-05 10:11:39,340 INFO: Using memory category 8GB 12792 2018-11-05 10:11:39,472 
INFO: Patch execution mode is set to: PRE_PHASE_FAILED 12993 2018-11-05 10:11:39,673 
INFO: Performing postUpdate task DeleteWeblogicServerCache (Delete Weblogic caches) 12993 2018-11-05 10:11:39,673 
INFO: Skipping Delete_Weblogic_caches due to services still running condition 12994 2018-11-05 10:11:39,674 
INFO: Performing postUpdate task ServiceControl (Start All Services) 13001 2018-11-05 10:11:39,681 
INFO: Executing /opt/rsa/am/server/rsaserv start all on command line 22946 2018-11-05 10:11:49,626 
INFO: Removing temporary file with patch properties /tmp/patch-properties.tmp Configuration step UpdateRollback:postUpdate [SUCCESS]
CauseThe rsaadmin password expiration is set to 60 days. If the password expires and is not reset, the Authentication Manager patch installation cannot proceed. 
Resolution
  1. Change the rsaadmin password through the Operations Console (Administration > Operating system access > Change Operating System Password).
  2. After changing the password, take a backup and then proceed with applying the patch or upgrade again.

Attachments

    Outcomes