000037901 - Users is not a valid user or group error when installing RSA Authentication Agent 8.0 for Web (IIS)

Document created by RSA Customer Support Employee on Sep 4, 2019
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000037901
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Agent for Web (IIS)
RSA Version/Condition: 8.0
IssueWhen trying to install the IIS Agent, it fails with the following error:

An error has occurred while applying security settings. Users is not a valid user or group." This could be a problem with the package or a problem connecting to a domain controller on the network. Check your network connecting and click retry or cancel to end install.
 


 
CauseDuring the installation, the installer is looking for a group called Users and it can't find it, the most common case is because the server language is not in English, thus it would be named the same but in a different language.

 
ResolutionThere are two workarounds to resolve this issue.  Either:
  • Go to the group in question and rename it to Users.  Run the installation, make sure it finishes, and after that revert back to the original group name; or
  • Create a temporary group called Users, run the installation and confirm that it completes successfully.

Attachments

    Outcomes