000037886 - When inactivating a cross reference field in RSA Archer it throws a warning message "The field that is trying to be updated is associated with a restricted inherited permission field. Can't change the status to Inactive"

Document created by RSA Customer Support Employee on Sep 6, 2019
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000037886
Applies ToRSA Product Set: Archer
RSA Version/Condition: 6.x
 
IssueWhen you try to inactivate a cross-reference or related field you get an error: "The field that is trying to be updated is associated with a restricted inherited permission field. Can't change the status to Inactive" How do you locate the fields that are referencing it?

User-added image
ResolutionTo resolve this issue you need to go to the record permission field and remove the reference to that application. To locate the record permission field you can use the below query:
 

select mt.module_name, lt.level_name, ft.field_name
from tblFieldInherit fi 
join tblIVFieldDef fd on fi.field_id=fd.field_id 
join tblIVFieldDefUserGroup ug on fd.field_id=ug.field_id
join tblFieldTranslation ft on fd.field_id=ft.field_id 
join tblLevel l on fd.level_id=l.level_id 
join tblLevelTranslation lt on l.level_id=lt.level_id 
join tblModuleTranslation mt on l.module_id=mt.module_id 
where ug.restrict_inherit_permission=1 and fi.inherit_from_related_record_field_id=<field_id here>


You will need to update the field_id with the field_id of the field you are setting to Inactive

Attachments

    Outcomes