000037782 - Getting Insert Image Failed in RSA Archer

Document created by RSA Customer Support Employee on Sep 6, 2019
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000037782
Applies ToRSA Product Set: Archer
RSA Version/Condition: 6.x
 
IssueIf you open the layout tab of a letterhead no images load. If you try to add an image you can select the company files images but when trying to add it to your letterhead you get an error message: “Insert image failed.”
User-added image

You can also get this error when adding an image to a text field in an application.

If you run an F12 browser trace you don’t get anything helpful
User-added image

Or you might get something stating an http status of 0
User-added image


 
ResolutionWhen accessing the images in your letterheads the URL is pulled from the Archer Control Panel and not the URL you are using to access Archer. Because of this you need to check the following URL’s in the Archer Control Panel:
  • Base URL in Instance->Web tab
  • Image Base Url if it is being used in the Instance->Web tab
If those look good you can test them from your browser by using the following URLs
<Base URL from ACP>/company_files/<instance id>/icons/<image file name>
<Base URL from ACP>/company_files/images/fieldhelp.gif

For example:
http://servername/RSAarcher/company_files/50000/icons/eGRC_header.jpg
http://servername/RSAarcher/images/fieldhelp.gif

Make sure you copy the base URL then add in the rest of the URL for testing. You need to test these URLs from both the WebServer(s) and the client machine. This will determine if there are any problems with accessing the images. If you receive any issues such as cert errors or are unable to load the image, you know that there is a problem and you either need to fix the URL or the certificate. A bad cert or URL can also cause issues with the emails going out with a red X instead of the images. In this case, you need to test the above URL on all of your job engine servers.
 

Attachments

    Outcomes