DSA-2019-134: RSA Identity Governance and Lifecycle Product Security Update for Multiple Vulnerabilities

Document created by RSA Product Team Employee on Sep 9, 2019Last modified by RSA Product Team Employee on Sep 12, 2019
Version 4Show Document
  • View in full screen mode
Dell EMC Identifier:DSA-2019-134
CVE Identifier:See Advisory
Severity:High
Severity Rating:View details below for individual CVSS Score for each CVE
Affected Products:
  • RSA Identity Governance and Lifecycle software version 7.1.1, prior to P02
  • RSA Identity Governance and Lifecycle software version 7.1.0, prior to P08
  • RSA Identity Governance and Lifecycle software version 7.0.2, all patch levels (all deployments)
  • RSA Identity Governance and Lifecycle software version 7.0.1, all patch levels (all deployments)
  • RSA Via Lifecycle and Governance software version 7.0, all patch levels (all deployments)
Summary:RSA Identity Governance and Lifecycle and RSA Via Lifecycle and Governance contains fixes for multiple security vulnerabilities that could potentially be exploited by malicious users to compromise the affected system.
Details:

• Code Injection Vulnerability (CVE-2019-3759)

The affected versions of RSA Identity Governance and Lifecycle software and RSA Via Lifecycle and Governance products contain a code injection vulnerability. A remote authenticated malicious user could potentially exploit this vulnerability to run custom Groovy scripts to gain limited access to view or modify information on the Workflow system.

 

CVSSv3 Base Score: 6.4 (AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)

 

• SQL Injection Vulnerability (CVE-2019-3760)

The affected versions of the RSA Identity Governance and Lifecycle and RSA Via Lifecycle and Governance products contain a SQL Injection vulnerability in Workflow Architect. A remote authenticated malicious user could potentially exploit this vulnerability to execute SQL commands on the back-end database to gain unauthorized access to the data by supplying specially crafted input data to the affected application.

 

CVSSv3 Base Score: 6.4 (AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)

 

• Stored Cross-site Scripting Vulnerability (CVE-2019-3761)

The affected versions of the RSA Identity Governance and Lifecycle and RSA Via Lifecycle and Governance products contain a stored cross-site scripting vulnerability in the Access Request module. A remote authenticated malicious user could potentially exploit this vulnerability to store malicious HTML or JavaScript code in a trusted application data store. When victim users access the data store through their browsers, the stored malicious code would gets executed by the web browser in the context of the vulnerable web application.

 

CVSSv3 Base Score: 5.4 (AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N)

 

• Information Exposure Vulnerability (CVE-2019-3763)
The affected versions of the RSA Identity Governance and Lifecycle and RSA Via Lifecycle and Governance products contains an information exposure vulnerability. The Office 365 user password may get logged in a plain text format in the Office 365 connector debug log file. An authenticated malicious local user with access to the debug logs may obtain the exposed password to use in further attacks.


CVSSv3 Base Score: 8.8 (CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Recommendation:

The following RSA Identity Governance and Lifecycle and RSA Via Lifecycle and Governance releases contain resolutions to these vulnerabilities:
• RSA Identity Governance and Lifecycle software version 7.1.1: 7.1.1, P02 or later
• RSA Identity Governance and Lifecycle software version 7.1.0: 7.1.0, P08 or later
• RSA Identity Governance and Lifecycle software version 7.0.2: Requires upgrading to 7.1.0, P08 or later
• RSA Identity Governance and Lifecycle software version 7.0.1: Requires upgrading to 7.1.0, P08 or later
• RSA Via Lifecycle and Governance software version 7.0: Requires upgrading to 7.1.0, P08 or later

 

Customers can obtain the documentation and software by downloading them from the Downloads area (RSA Downloads Area ) in the RSA Identity Governance and Lifecycle space of RSA Link.  RSA recommends all customers upgrade at the earliest opportunity.

Credit:RSA would like to thank Jakub Palaczynski for reporting CVE-2019-3759, CVE-2019-3760, and CVE-2019-3761
Severity Rating:For an explanation of Severity Ratings, refer to Dell’s Vulnerability Disclosure Policy. RSA recommends all customers take into account both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.
EOPS Policy:RSA has a defined End of Primary Support policy associated with all major versions. Please refer to the Product Version Life Cycle for additional details.
Legal Information:

Read and use the information in this RSA Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this advisory, contact RSA Customer Support. RSA Security LLC and its affiliates, including without limitation, its ultimate parent company, Dell Technologies, distribute RSA Security Advisories in order to bring to the attention of users of the affected RSA products, important security information.

 

RSA recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. RSA disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement.

 

In no event shall RSA, its affiliates or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if RSA, its affiliates or its suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.

Attachments

    Outcomes