000037955 - Error "Unable to retrieve current platform specification" when upgrading RSA Authentication Manager 8.x

Document created by RSA Customer Support Employee on Sep 18, 2019
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000037955
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
IssueWhile upgrading RSA Authentication Manager on a virtual machine through the Operations Console, the upgrade fails with the following error, which appears in the Advanced Status View:
 
[INFO] Invoking config engine goal UpdateRollback:preUpdate
0 2019-08-21 12:06:00,783 INFO: Arguments: [UpdateRollback.preUpdate]
993 2019-08-21 12:06:01,776 INFO: Will not attempt to fix line endings in patch source files
1023 2019-08-21 12:06:01,806 INFO: Script source dir: /tmp/rsa_update/installer/config/src/scripts
1023 2019-08-21 12:06:01,806 INFO: Patch Script source dir: /tmp/rsa_update/iso/rsa/scripts
1295 2019-08-21 12:06:02,078 INFO: Reading configuration from Config.groovy
2023 2019-08-21 12:06:02,806 INFO: Running task UpdateRollback.preUpdate
4757 2019-08-21 12:06:05,540 INFO: Executing free
5201 2019-08-21 12:06:05,984 INFO: Total Memory: 4057304 KB
5211 2019-08-21 12:06:05,994 INFO: Using memory category 4GB
[copy] Copying 1 file to /opt/rsa/am/updates/backup
[copy] Copying /tmp/rsa_update/iso/PatchManifest.xml to /opt/rsa/am/updates/backup/PatchManifest.xml
[mkdir] Created dir: /opt/rsa/am/updates/backup/opt/rsa/am/utils/etc
5716 2019-08-21 12:06:06,499 INFO: Copying /opt/rsa/am/utils/etc/patchHistory.dat to /opt/rsa/am/updates/backup/opt/rsa/am/utils/etc/patchHistory.dat 6123 2019-08-21 12:06:06,906 INFO: Initialized patch properties
6125 2019-08-21 12:06:06,908 INFO: Patch execution mode is set to: UPDATE
6125 2019-08-21 12:06:06,908 INFO: Database started is set to: false
6127 2019-08-21 12:06:06,910 INFO: Retrieving platform specification.
6602 2019-08-21 12:06:07,385 INFO: Process return code is: 0
6607 2019-08-21 12:06:07,390 INFO: Output is: VM
6608 2019-08-21 12:06:07,391 INFO: Current platform is: hardware
6609 2019-08-21 12:06:07,392 FATAL: Unable to retrieve current platform specification. Platform mismatch detected.
6636 2019-08-21 12:06:07,419 FATAL: Unable to retrieve current platform specification. Platform mismatch detected.
java.lang.AssertionError: Unable to retrieve current platform specification. Platform mismatch detected.


at com.rsa.plugins.install.CommandLineInstallEngine.fail(CommandLineInstallEngine.groovy:282)
at com.rsa.plugins.install.CommandLineInstallEngine$fail.call(Unknown Source)
at com.rsa.plugins.install.GroovyInstallEngine.fail(GroovyInstallEngine.groovy:31)
at com.rsa.plugins.install.GroovyInstallEngine$_buildScriptEnvironment_closure5.doCall(GroovyInstallEngine.groovy:159)
at PatchUtils.setCurrentPlatformSpec(PatchUtils.groovy:899) at PatchUtils$setCurrentPlatformSpec.call(Unknown Source)
at PatchUtils.initPatchProperties(PatchUtils.groovy:98) at PatchUtils$initPatchProperties.call(Unknown Source)
at UpdateRollback$_preUpdate_closure1.doCall(UpdateRollback.groovy:12) at UpdateRollback$_preUpdate_closure1.doCall(UpdateRollback.groovy)
at Utils.withArtifacts(Utils.groovy:48) at Utils$withArtifacts.call(Unknown Source) at UpdateRollback.preUpdate(UpdateRollback.groovy:9)
at com.rsa.plugins.install.GroovyInstallEngine.invokeScript(GroovyInstallEngine.groovy:68)
at com.rsa.plugins.install.GroovyInstallEngine$_runTask_closure2.doCall(GroovyInstallEngine.groovy:57)
at com.rsa.plugins.install.GroovyInstallEngine.runTask(GroovyInstallEngine.groovy:56)
at com.rsa.plugins.install.GroovyInstallEngine$_runTasks_closure3.doCall(GroovyInstallEngine.groovy:106)
at com.rsa.plugins.install.GroovyInstallEngine.runTasks(GroovyInstallEngine.groovy:105)
at com.rsa.plugins.install.GroovyInstallEngine$runTasks.call(Unknown Source)
at com.rsa.plugins.install.CommandLineInstallEngine.main(CommandLineInstallEngine.groovy:40)


Exception in thread "Main Thread" java.lang.AssertionError:
Unable to retrieve current platform specification. Platform mismatch detected.


at com.rsa.plugins.install.CommandLineInstallEngine.fail(CommandLineInstallEngine.groovy:287)
at com.rsa.plugins.install.CommandLineInstallEngine$fail$0.call(Unknown Source)
at com.rsa.plugins.install.GroovyInstallEngine.fail(GroovyInstallEngine.groovy:35)
at com.rsa.plugins.install.GroovyInstallEngine$fail.callCurrent(Unknown Source)
at com.rsa.plugins.install.GroovyInstallEngine.invokeScript(GroovyInstallEngine.groovy:88)
at com.rsa.plugins.install.GroovyInstallEngine$_runTask_closure2.doCall(GroovyInstallEngine.groovy:57)
at com.rsa.plugins.install.GroovyInstallEngine.runTask(GroovyInstallEngine.groovy:56)
at com.rsa.plugins.install.GroovyInstallEngine$_runTasks_closure3.doCall(GroovyInstallEngine.groovy:106)
at com.rsa.plugins.install.GroovyInstallEngine.runTasks(GroovyInstallEngine.groovy:105)
at com.rsa.plugins.install.GroovyInstallEngine$runTasks.call(Unknown Source)


at com.rsa.plugins.install.CommandLineInstallEngine.main(CommandLineInstallEngine.groovy:40)


Configuration step UpdateRollback:preUpdate [FAILED]
[ERROR] Error: Failed to invoke update engine: Failed to prepare the update.
java.lang.Exception: Failed to prepare the update.


at com.rsa.am.updateengine.tasks.BaseUpdateEngineTask.doExecute(BaseUpdateEngineTask.java:56)
at com.rsa.am.updateengine.tasks.Task.execute(Task.java:136)
at com.rsa.am.updateengine.components.impl.TaskManagerImpl.doExecuteTask(TaskManagerImpl.java:86)
at com.rsa.am.updateengine.components.impl.TaskManagerImpl.execute(TaskManagerImpl.java:41)
at com.rsa.am.updateengine.components.impl.UpdateInstallerImpl.run(UpdateInstallerImpl.java:30)


[INFO] Invoking config engine goal UpdateRollback:postUpdate
1 2019-08-21 12:06:08,403 INFO: Arguments: [UpdateRollback.postUpdate]
921 2019-08-21 12:06:09,323 INFO: Will not attempt to fix line endings in patch source files
950 2019-08-21 12:06:09,352 INFO: Script source dir: /tmp/rsa_update/installer/config/src/scripts
951 2019-08-21 12:06:09,353 INFO: Patch Script source dir: /tmp/rsa_update/iso/rsa/scripts
1071 2019-08-21 12:06:09,473 INFO: Reading configuration from Config.groovy
1788 2019-08-21 12:06:10,190 INFO: Running task UpdateRollback.postUpdate
4541 2019-08-21 12:06:12,943 INFO: Executing free 4985 2019-08-21 12:06:13,387 INFO: Total Memory: 4057304 KB
4997 2019-08-21 12:06:13,399 INFO: Using memory category 4GB
5035 2019-08-21 12:06:13,437 INFO: Patch execution mode is set to: PRE_PHASE_FAILED
5056 2019-08-21 12:06:13,458 INFO: Performing postUpdate task DeleteWeblogicServerCache (Delete Weblogic caches)
5056 2019-08-21 12:06:13,458 INFO: Skipping Delete_Weblogic_caches due to services still running condition
5056 2019-08-21 12:06:13,458 INFO: Performing postUpdate task ServiceControl (Start All Services)
5056 2019-08-21 12:06:13,458 INFO: Skipping Start_All_Services due to services still running condition
5058 2019-08-21 12:06:13,460 INFO: Removing temporary file with patch properties /tmp/patch-properties.tmp
Configuration step UpdateRollback:postUpdate [SUCCESS]
[INFO] Deleting update installer temporary directory
CauseThe issue is that there is a mismatch in the /opt/rsa/am/etc/platform file and the actual appliance  form factor deployed.

For example the actual appliance used is virtual appliance but the platform file contains the word hardware, as shown here:
 
rsaadmin@am82p:~> cat /opt/rsa/am/etc/platform
hardware


 
ResolutionTo resolve the issue,
  1. Launch an SSH client, such as PuTTY.
  2. Login to the primary Authentication Manager server as rsaadmin and enter the operating system password.

Note that during Quick Setup another user name may have been selected. Use that user name to login.



  1. Type the following command on the RSA Authentication Manager primary or replica instance(s) where the platform needs to be identified:

rsaadmin@am83p:~> cat /opt/rsa/am/etc/platform


  1. You will find in the configuration file set to hardware when it should be virtual:

rsaadmin@am83p:~> cat /opt/rsa/am/etc/platform
hardware


  1. To change the configuration file to virtual, first open a text editor:

rsaadmin@am83p:~> vim /opt/rsa/am/etc/platform


  1. Press i to enter Insert mode.
  2. Delete the word hardware and type virtual .  Note that the word must be all in lowercase.
  3. Press ESC to exit Insert mode.
  4. Type :wq! to save and exit.
  5. Try the upgrade again and it will complete successfully.

Attachments

    Outcomes