000037165 - "No configured interfaces were detected" error after finishing Quick Setup on a new RSA Authentication Manager 8.4 server

Document created by RSA Customer Support Employee on Oct 15, 2019Last modified by RSA Customer Support Employee on Oct 15, 2019
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000037165
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.4
Issue
  • After configuring a new RSA Authentication Manager 8.4 server, then finishing Quick Setup and rebooting, the following error message is received


No configured interfaces were detected. Please enter the settings for the first interface.


  • After re-entering the configuration, the system continues to boot, but the Authentication Manager services are all down. 
CauseRSA Authentication Manager 8.4 is based on SUSE Linux Enterprise Server 12 Service Pack 3 which uses a service named wicked to control the network interfaces.  As of SLES 12, wicked-controlled network interfaces are started with their IP address only if a carrier signal was detected. Therefore, if a signal is not detected during boot, the interfaces will not be assigned IP addresses and RSA Authentication Manager services fail to start if there are no active and configured network interfaces. 
ResolutionResolve the network issue causing the signal to not be detected during boot. Then restart the Authentication Manager services. 
WorkaroundForce wicked to assign IP addresses to network interfaces even if no signal is detected by adding LINK_REQUIRED='no' to the respective /etc/sysconfig/network/ifcfg-* file. To do so, follow these steps:
  1. Enter the network configuration for the system to continue the booting process.
  2. Access the system from the console.
  3. Change to root using the following command:


rsaadmin@am84p:~> sudo su -
rsaadmin's password: <enter operating system password>


  1. Add LINK_REQUIRED='no' to the configuration file of the first network interface eth0:


am84p:~ # echo "LINK_REQUIRED='no'" >> /etc/sysconfig/network/ifcfg-eth0


  1. If using multiple interfaces, add the same line to their respective configuration files. The configuration files are all in the same directory named ifcfg-eth0ifcfg-eth1ifcfg-eth2, etc.
  2. Restart the network service for the changed to take effect using the following command:


am84p:~ # service network restart
Shutting down network interface   
    eth0      device: Intel Corporation 82545EM Gigabit Ethernet Co           done
Shutting down service network . . . . . . . . . . . . . .                     done
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces
  eth0    device: Intel Corporation 82545EM Gigabit Ethernet Co
   eth0    IP address 192.168.2.50/23                                         done
Setting up service network . . . . . . . . . . . . . .                        done


  1. Verify that the network interfaces are up and assigned an IP:


am84p:~ # ip address
1:  lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 gdisc noqueue state UNKNOWN
     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
     inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
     inet 127.0.0.1/8 brd 127.255.255.255 scope host secondary lo
     inet6 ::1/128 scope host
        valid_lft forever preferred_lft forever
2: eth0 <BROADCAST,MULTICAST,UP,LOWER_UP> ntu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:01:0c:38 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.50/23 brd 102.168.3.255 scope global eth0
    inet6 fe80::250:56ff:fe01:c38/64 scope link
       valid_lft forever preferred_lft forever


  1. Restart Authentication Manager services to bring them back up:


am84p:~ # /opt/rsa/am/server/rsaserv restart all

Attachments

    Outcomes