000038137 - The data feed failed validation error occurs when trying to import data into a user field in RSA Archer

Document created by RSA Customer Support Employee on Nov 19, 2019Last modified by RSA Customer Support Employee on Nov 26, 2019
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000038137
Applies ToRSA Product Set: Archer
RSA Version/Condition: 6.x
 
IssueIf you have a Record Permission field or a User/Group field and try to import users into it, the import fails.

In the data feed's Run Detail Messages, the following messages are displayed:

The data feed failed validation.



The value in field 'Column Name' cannot be converted, the item will be dropped.

 

User-added image


The Archer JobFramework logs show the following error:

<E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent">
  <System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system">
    <EventID>1</EventID>
    <Type>3</Type>
    <SubType Name="Error">0</SubType>
    <Level>2</Level>
    <TimeCreated SystemTime="2019-11-14T20:50:51.9613324Z" />
    <Source Name="ArcherTech.DataFeed" />
    <Correlation ActivityID="{0d3dbea4-61d7-4bd3-b7b7-d9f66e9702c2}" />
    <Execution ProcessName="ArcherTech.JobFramework.Job" ProcessID="15108" ThreadID="1" />
    <AssemblyVersion>6.7.0.1184</AssemblyVersion>
    <Channel />
    <Computer>ServerName</Computer>
  </System>
  <ApplicationData>
    <TraceData>
      <DataItem>
        <TraceRecord Severity="Error" xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord">
          <TraceIdentifier>ArcherTech.DataFeed</TraceIdentifier>
          <Description>The data feed failed pre-validation.</Description>
          <AppDomain>ArcherTech.JobFramework.Job.exe</AppDomain>
          <ContextData>
            <LogReferenceId>111419-205051-9463</LogReferenceId>
            <DataFeedId>2057</DataFeedId>
            <DataFeedName>Data_Import_Feed_11142019_850_PM</DataFeedName>
            <DataFeedHistoryId>8437</DataFeedHistoryId>
          </ContextData>
        </TraceRecord>
      </DataItem>
    </TraceData>
  </ApplicationData>
</E2ETraceEvent>
CauseOne thing that can cause this is where Archer is unable to locate the users when the users are part of a domain and you are passing the domain in your import. If you use the default import settings, the escape character will remove the backslash.

For example, you have a csv that specifies domain\user like the following:
 
User-added image



In the Data Import Wizard, notice the backslashes are removed.
 
User-added image
ResolutionThe default escape character is set to backslash so you will need to select a different escape sequence character when performing the import like a tilde (~).  Making this change should allow the import to run successfully.

User-added image

Attachments

    Outcomes