000038215 - RSA Archer Unexpected Error When Adding Users

Document created by RSA Customer Support Employee on Dec 19, 2019
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000038215
Applies ToRSA Product Set: Archer
RSA Product/Service Type: Archer
IssueWhen trying to add a new user through Manage Users, you will receive an Unexpected Error:

User-added image

When closing the popup, the page stays in the Add User form but when clicking Save, it displays "undefined" in Created By and Updated By fields:

User-added image

Below is what is recorded in the w3wp logs:
 

<E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent">
    <System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system">
        <EventID>0</EventID>
        <Type>3</Type>
        <SubType Name="Error">0</SubType>
        <Level>2</Level>
        <TimeCreated SystemTime="2019-12-06T15:12:20.6303859Z" />
        <Source Name="Archer.Silverlight.WCF" />
        <Correlation ActivityID="{00000000-0000-0000-0000-000000000000}" />
        <Execution ProcessName="w3wp" ProcessID="7864" ThreadID="65" />
        <AssemblyVersion>6.6.300.1025</AssemblyVersion>
        <Channel />
        <Computer></Computer>
    </System>
    <ApplicationData>
        <TraceData>
            <DataItem>
                <TraceRecord Severity="Error" xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord">
                    <TraceIdentifier>Archer.Silverlight.WCF</TraceIdentifier>
                    <UserId></UserId>
                    <LogReferenceId>120619-151220-6303</LogReferenceId>
                    <Description>Parameter {0} can't be 0 or negative number.
Parameter name: accessRoleId</Description>
                    <AppDomain>/LM/W3SVC/1/ROOT-1-132200750498735430</AppDomain>
                    <Exception>
                        <ExceptionType>System.ArgumentException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType>
                        <Message>Parameter {0} can't be 0 or negative number.
Parameter name: accessRoleId</Message>
                        <Source>ArcherTech.Kernel</Source>
                        <StackTrace>   at ArcherTech.Kernel.Utility.BrokerHelper.ValidateIntegerParameter(Int32 parm, String parmName)
   at ArcherTech.Kernel.Brokers.AccessRoleBroker.Get(Int32 accessRoleId, Boolean checkPermission)
   at ArcherTech.Kernel.Managers.AccessRoleManager.GetDefault(SessionContext sessionContext)
   at ArcherTech.Web.Silverlight.ManageUserDataBuilder.BuildDefaultRole(ManageUserData returnValue)
   at ArcherTech.Web.Silverlight.ManageUserDataBuilder.Build(ManageUserDataLoadInfo input)
   at SyncInvokeGetManageUserData(Object , Object[] , Object[] )
   at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]&amp; outputs)
   at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc&amp; rpc)
   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc&amp; rpc)
   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc&amp; rpc)
   at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)</StackTrace>
                    </Exception>
                </TraceRecord>
            </DataItem>
        </TraceData>
    </ApplicationData>
</E2ETraceEvent>




 
CauseThis issue can be caused by no default Access Roles selected.
ResolutionNavigate to Administration > Access Control > Access Roles and verify a default role has been selected.

Attachments

    Outcomes