000038854 - Authentication context not added error when trying to authenticate using RSA Authentication Agent 2.0 for AD FS

Document created by RSA Customer Support Employee on May 13, 2020Last modified by RSA Customer Support Employee on May 14, 2020
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000038854
Applies ToRSA Product Set:  SecurID
RSA Product/Service Type:  Authentication Agent for AD FS
RSA Version/Condition:  2.0.x
IssueThis article explains how to resolve the following error with the RSA Authentication Agent 2.0.x for AD FS when using the agent for two factor authentication.
  • Configuring multifactor authentication (MFA) on a Windows Server with RSA Authentication Agent 2.0.x for AD FS with RSA SecurID for secondary authentication has no issues and user authentication is successful.
  • While configuring MFA on a Windows Server with RSA Authentication Agent 2.0.x for AD FS with RSA SecurID for primary authentication, breaks authentication. 
  • The user is not prompted to enter the passcode and is presented with the following error:

Cannot authenticate. Contact your administrator.

User-added image
  • The RSA Authentication Activity Monitor shows no authentication from that agent.
  • The log snippet below (by default in C:\Program Files\RSA\RSA Authentication Agent\AD FS MFA Adapter\logs/rsa_adfs.log) has the following errors:

2020-05-11 11:51:03,808 [52] INFO AuthnAdapter - Claim Type =
http://schemas.microsoft.com/ws/2008/06/identity/claims/windowsaccountname
2020-05-11 11:51:03,808 [52] INFO AuthnAdapter - BeginAuthentication: Username obtained from AD FS: vcloud\jdoe
2020-05-11 11:51:03,808 [52] INFO AuthnAdapter - BeginAuthentication:
Initial state: ActivityId = 89257732-629e-4bd2-8c00-0080010000cf, ContextID = 42e89c9c-2561-40f2-9507-d3fedb6a5c10,
User = jdoe, lcid = 1033
2020-05-11 11:51:03,808 [52] DEBUG AuthnContextValidator - Searching authentication context...
2020-05-11 11:51:03,808 [52] DEBUG AuthnContextValidator - Continuing search...
2020-05-11 11:51:03,808 [52] DEBUG AuthnContextValidator - Searching authentication context...
2020-05-11 11:51:03,808 [52] DEBUG AuthnContextValidator - Adding default authentication context
2020-05-11 11:51:03,808 [52] DEBUG AuthSessionAdapter - BeginAuthentication(): Authentication context not added.
2020-05-11 11:51:03,808 [52] INFO AuthSessionAdapter - BeginAuthentication(): Initial state: ActivityId =
89257732-629e-4bd2-8c00-0080010000cf, ContextId = 42e89c9c-2561-40f2-9507-d3fedb6a5c10, authState = NotAuthenticated
ResolutionTo resolve this issue,
  1. Ensure that the RSA SecurID Authentication Agent 2.0.2 for AD FS and RSA SecurID Authentication Agent 2.0.2 GPO are installed.
  2. Review the RSA Authentication Agent 2.0.2 for Microsoft AD FS Group Policy Object Template Guide.
  3. From Local Authentication Settings, set Validate the AD FS authentication context to Disabled.

User-added image


  1. Following the steps on page 28 of the RSA Authentication Agent 2.0.2 for Microsoft® AD FS Administrator's Guide, unregister the agent then re-register it.
  2. Restart AD FS services.
  3. Users are now be prompted to enter their RSA passcode. Authentication should work as expected. 
NotesAgents can be unregistered and registered using the MFAAuthProviderConfigSettings.ps1 scripts that are included with the agent.

Attachments

    Outcomes