000039423 - Notification email does not show image on header and footer in Archer

Document created by RSA Customer Support Employee on Oct 28, 2020
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Article Number000039423
Applies ToProduct Set: Archer Suite
Product/Service Type: Archer (On-Premise)
Version/Condition: 6.x
Issue
  • Company_files is on an external server and after applying some changes in the Network IP, the Notification email does not show the image on the header and footer, instead, it shows red-cross images.
  • The following error is thrown in the Jobframework logs.

    <ApplicationData>
      <TraceData>
        <DataItem>
          <TraceRecord Severity="Error" xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord">
            <TraceIdentifier>ArcherTech.Notifications</TraceIdentifier>
            <Description>Error loading the bytes for an embedded image in the email generated for notification template '##########' with id = '###'.</Description>
            <AppDomain>ArcherTech.JobFramework.Job.exe</AppDomain>
            <Exception>
              <ExceptionType>ArcherTech.Common.Exceptions.ImageLoadingNotificationException, ArcherTech.Common, Version=6.7.200.1021, Culture=neutral, PublicKeyToken=null</ExceptionType>
              <Message>Error loading the bytes for an embedded image in the email generated for notification template '##########' with id = '###'.</Message>
              <Source />
              <ContextData>
                <Resolution>Please verify that you have access to the location where the image is stored. For further support, please contact your system administrator.</Resolution>
                <ImageName>#######.png</ImageName>
                <ImagePath>https://#######/RSAarcher/company_files/50000/icons/##############.png</ImagePath>
              </ContextData>
              <StackTrace />
              <InnerException>
                <ExceptionType>System.Net.WebException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=##########</ExceptionType>
                <Message>Unable to connect to the remote server</Message>
                <Source>System</Source>
                <StackTrace> at System.Net.HttpWebRequest.GetResponse()
    at ArcherTech.Notifications.ExtensionMethods.EmailMessageExtensionMethods.GetImage(SessionContext sessionContext, KeyValuePair`2 imageName, Notification notification)</StackTrace>
                <InnerException>
                  <ExceptionType>System.Net.Sockets.SocketException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=##########</ExceptionType>
                  <Message>A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond ##.##.##.###:###</Message>
                  <Source>System</Source>
                  <StackTrace> at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
    at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket&amp; socket, IPAddress&amp; address, ConnectSocketState state, IAsyncResult asyncResult, Exception&amp; exception)</StackTrace>
                </InnerException>
              </InnerException>
            </Exception>
          </TraceRecord>
        </DataItem>
      </TraceData>
    </ApplicationData>

Cause
  • Error in the logs is indicating that the path is not accessible and pointing to the old IP address and whenever the image is opened from inside and outside the server it can be accessed normally.
  • The loopback IP address 127.0. 0.1 was located in the Hosts file instead of the IP of the external Company_files server.
Resolution
  • Connect to the server using RDP.

  1. Open the following path C:\Windows\System32\drivers\etc.
  2. Open the Hosts file.
  3. Add the IP of the external Company_files server with the FQDN.
  4. Save the file.

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