000032805 - RSA Adaptive Authentication on Prem (AAoP) 7.1 P5 Security Vulnerabilities for Multiple Embedded Components (CVE-2011-2730) - False Positive

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 14, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000032805
Applies ToRSA Product Set: Adaptive Authentication (OnPrem)

RSA Product/Service Type: Adaptive Authentication (OnPrem)

RSA Version/Condition: 7.1 P5
CVE IDCVE-2011-2730
Article SummarySecurity vulnerability found with open source libraries using Black Duck Scan
CVE-2011-2730High7.5appl
Component NameComponent VersionVulnerabilitySeverityCVSSFolderFile Name
Spring Framework - springframework3.0.5CVE-2011-2730High7.5applicationsRel1.zip/applicationsRel1/wscredentialmanager/WEB-INF/libspring-tx-3.0.5.RELEASE.jar
Spring Web - org.springframework:spring-web3.0.5CVE-2011-2730High7.5applicationsRel1.zip/applicationsRel1/wscredentialmanager/WEB-INF/libspring-web-3.0.5.RELEASE.jar
spring-asm3.0.5CVE-2011-2730High7.5applicationsRel1.zip/applicationsRel1/wscredentialmanager/WEB-INF/libspring-asm-3.0.5.RELEASE.jar
spring-webmvc3.0.5CVE-2011-2730High7.5applicationsRel1.zip/applicationsRel1/wscredentialmanager/WEB-INF/libspring-webmvc-3.0.5.RELEASE.jar
Alert ImpactNot Applicable
Technical DetailsFalse positive
Technical Details ExplanationAA-17133 Security Vulnerabilities found with open source libraries using Black Duck Scan
spring-tx-3.0.5.RELEASE.jar CVE-2011-2730
spring-web-3.0.5.RELEASE.jar CVE-2011-2730
spring-asm-3.0.5.RELEASE.jar CVE-2011-2730
spring-webmvc-3.0.5.RELEASE.jar CVE-2011-2730

Description
Prior to JSP 2.0, Expression Language (EL) was not supported. To enable the use of EL in web applications based on earlier JSP specifications, some Spring MVC tags provide EL support independently of the Servlet/JSP container. The evaluation of EL is enabled by default. When used on containers that do support EL, the attributes can be evaluated for EL twice. Once by the container and once by the tag. This can lead to unexpected results that include disclosure of information and remote code execution (initially only information disclosure was documented but a subsequent report showed the possibility of code execution).
 
CVSS Score
CVSS Base Score : 4.9
CVSS v2 Vector (AV:A/AC:M/Au:S/C:P/I:P/A:P)
ResolutionIn AAoP we do not use the spring MVC tags that provided the Expression Language support prior to JSP 2.0.  Therefore, AAoP is not affected by this vulnerability.

 

Disclaimer

Read and use the information in this RSA Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this product alert, contact RSA Software Technical Support at 1- 800 995 5095. RSA Security LLC and its affiliates, including without limitation, its ultimate parent company, EMC Corporation, distributes RSA Security Advisories in order to bring to the attention of users of the affected RSA products, important security information. RSA recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided 'as is' without warranty of any kind. RSA disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event, shall RSA, its affiliates or suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if RSA, its affiliates or suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.

Attachments

    Outcomes