000032027 - RSA Authentication Manager 8.1 and Insecure Serialized Object in the Oracle WebLogic Server (CVE-2015-4852) - False Positive

Document created by RSA Customer Support Employee on Jun 14, 2016
Version 1Show Document
  • View in full screen mode

Article Content

Article Number000032027
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager 
RSA Version/Condition: 8.x
Platform: Oracle WebLogic Server 10.3.6.0, 12.1.2.0, 12.1.3.0, 12.2.1.0
CVE IDCVE-2015-4852
Article Summary

Information about CVE-2015-4852 - A vulnerability in Oracle WebLogic Server.


CVE#ComponentProtocolSub-
   component
Remote Exploit without Auth.?CVSS VERSION 2.0 RISK (see Risk Matrix Definitions)Supported Versions Affected
Base ScoreAccess VectorAccess ComplexityAuthen-
   tication
Confiden-
   tiality
IntegrityAvail-
   ability
CVE-2015-4852Oracle WebLogic ServerT3WLS SecurityYes7.5NetworkLowNonePartial+Partial+Partial+10.3.6.0,  12.1.2.0, 12.1.3.0,
   12.2.1.0
Link to Advisorieshttp://www.oracle.com/technetwork/topics/security/alert-cve-2015-4852-2763333.html
Alert ImpactNot Applicable
Technical DetailsFalse positive
Technical Details Explanation

Description:
This Security Alert addresses security issue CVE-2015-4852, a deserialization vulnerability involving Apache Commons and Oracle WebLogic Server.
This is a remote code execution vulnerability and is remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.

Affected Products and Versions:
Oracle WebLogic Server, versions 10.3.6.0, 12.1.2.0, 12.1.3.0, 12.2.1.0 are affected.

Analysis:
The problem is with serialized objects passed over T3/T3S connections to WebLogic which are not properly validated.  Oracle identified the affected versions:

Oracle WebLogic Server, versions 10.3.6.0, 12.1.2.0, 12.1.3.0, 12.2.1.0.

RSA Authentication Manager 8.1 uses WebLogic version 12.1.1.0 (updated to 12.1.1.0.9 in Authentication Manager 8.1 SP1 patch P2 and later).
Response:
Authentication Manager 8.1 SP1 does not use a version of WebLogic which is affected by this issue.

 

Disclaimer

Read and use the information in this RSA Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this product alert, contact RSA Software Technical Support at 1- 800 995 5095. RSA Security LLC and its affiliates, including without limitation, its ultimate parent company, EMC Corporation, distributes RSA Security Advisories in order to bring to the attention of users of the affected RSA products, important security information. RSA recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided 'as is' without warranty of any kind. RSA disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event, shall RSA, its affiliates or suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if RSA, its affiliates or suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.

Attachments

    Outcomes