000032534 - Export the Master Reports List in Archer

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000032534
Applies ToRSA Product Set: Archer
 
IssueOver time, a large number of global reports may get created in the Archer instance. Thus, users might like to export the list of the reports so they can review them to determine which reports to be kept and which ones to be deleted.
TasksPrerequisites:
Download the free application Notepad++
https://notepad-plus-plus.org/
 
Resolution
  1. Log on to the Archer web server. Open a browser window and go to Archer's Web Service API (Application Program Interface) General page:
[my_archer_base_url/ws/general.asmx

  1. Click CreateUserSessionFromInstance and enter logon information for an account that has access to the Master Reports List in the Archer instance.
    1. UserName
    2. InstanceName
    3. Password
  2. Click Invoke. A session token for the user account will be generated similar to:
BDDD45BEA9D52F1A8F13802B8C2FFF63

  1. Copy the session token to your clipboard.
  2. Browse to Archer's Web Service API Search page:
[my_archer_base_url/ws/search.asmx

  1. Click GetReports.  
  2. Paste in the session token you generated above and click Invoke. A list of all global reports for this instance will be displayed in the browser window, in XML format.
  3. In the browser's menu bar, go to File > Save As and save the output as an XML file
  4. Open the XML file in Notepad++.
    1. Select all of the text in the file with [Ctrl]+[A].
    2. Go to Plugins > XML Tools.
    3. Select Convert Selection Text to XML.
    4. Go to Plugins > XML Tools again.
    5. Select Pretty Print (XML Only - with Line Breaks)
    6. Save and close the file.
  5. Open a new blank Excel worksheet, and go to the Data tab.
  6. In the Get External Data section, select From Other Sources > XML data import.
  7. Follow the instructions in the import wizard to import the XML file you created above.

 

Attachments

    Outcomes