000030281 - Which Java versions are supported for non Hardware Appliance AFX installations in RSA IMG?

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000030281
Applies ToRSA Product Set: Identity Management and Governance
RSA Product/Service Type: AFX
RSA Version/Condition: 6.9.x
IssueDoes upgrading Red Hat Linux  (and with it Java) cause any problem with installing AFX?
The AFX documentation is conflicting:
On page 15 we write:
JDK/JRE 1.6 JRE 1.6 is required. Oracle Java 1.6 and 1.7 as well as IBM Java 1.6 are supported
as well as any future Java release.

Yet, for the installation we are referring to 'Install a New AFX Server' on page 20
where,  in step 2, we state:
For the “afx account,” export JAVA_HOME and put $JAVA_HOME/bin in the PATH. Note that
JAVA_HOME must point to a JAVA 1.6 installation.

 
 
ResolutionJava 1.7 has not been tested with 6.x.
Customers should stick to a Java 1.6 home for the AFX installation and make sure JAVA_HOME is defined correctly for AFX.

Attachments

    Outcomes