000029626 - How to configure database backups to NFS instead of Local

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 4Show Document
  • View in full screen mode

Article Content

Article Number000029626
IssueBy default the IMG ACM server's database backups are written to a local directory.  This article will give the steps on how to configure your server to store the databases backups to an NFS mounted share.
TasksThese steps will change the location from writing to a local directory to a directory hosted on a remote NFS server.
NOTE: Your NFS server should be connected,configured, and tuned for the best transfer speed possible.  The network performance to the NFS server will have a direct impact on the amount of time that the backup will take to complete.  If there are issues with backups failing, the failure will need to be demonstrated or reproduced using the default local hard drive for support to triage.
First we should move the existing contents of the local backup folder to a different location for safe keeping:
User-added image
Now you use the AveksaExportImportDir as your mount point for your NFS share.
Here is an example using a non-persistent command:
User-added image
The remote NFS server's IP is 192.168.26.107 and it has a folder that was shared named /nfs-backups.
Here is an example of a persistent configuration by having an entry in /etc/fstab:
User-added image
Now when a backup is created either scheduled or by choosing Edit and selecting "Now", the file will be written to the directory /home/oracle/AveksaExportImportDir as it always has, however that directory is now a pointer to the remote NFS server.
Attached is a document on setting up an NFS share to a RedHat server just for reference, using the IP addresses and folders demonstrated above.
Steps to reverse this configuration and have backups resume to the local drive:
manually reversing the non-persistent command:
umount /home/oracle/AveksaExportImportDir
manually reversing the persistent command:
edit /etc/fstab and comment out the line that references /home/oracle/AveksaExportImportDir
umount /home/oracle/AveksaExportImportDir
 

Outcomes