000017054 - Error message 'wrong version number' when attempting to connect to an RSA Security Analytics 10.4 appliance service via NwConsole

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000017054
Applies ToRSA Security Analytics
RSA Security Analytics 10.4.0.0 and above
RSA Security Analytics Core Appliance
RSA Security Analytics Console (NwConsole)
IssueError message "wrong version number" when attempting to connect to an RSA Security Analytics 10.4 appliance service via NwConsole.

Attempting to connect to an SSL-enabled appliance running RSA Security Analytics 10.4 using the syntax login localhost:5000x:ssl <username> results in the following error:  Connect failed with error "wrong version number"


CauseThis issue occurs because RSA Security Analytics 10.4 uses a dedicated port for each service level, 5600x, when SSL is enabled.  While this allows a user to login with NwConsole using both the SSL and non-SSL port, the ability to connect to the non-SSL port with the :ssl flag in NwConsole is no longer available.
Resolution

In order to successsfully connect to a service level via NwConsole on an RSA Security Analytics 10.4 core appliance where SSL is enabled, the following syntax options should be used:


  • login localhost:5000x <username>
  • login localhost:5600x:ssl <username>

 


NotesFor more information on the network architecture and port changes in Security Analytics 10.4, refer to the RSA Security Analytics 10.4 User Guide.
Legacy Article IDa68256

Attachments

    Outcomes