000017262 - Installation of patch RSA DLP 9.6 SP2 P1 fails with error 2727

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000017262
Applies ToRSA Data Loss Prevention (DLP) 9.6 SP2
Attempting to upgrade to DLP 9.6 SP2 P1
 
IssueInstallation of RSA DLP 9.6 SP2 P1
Error 2727.The directory entry '_6CE3EE5A35DE40ED87686ED987713F56' does not exist in the Directory table.
Example:
CauseBuild number 9.6.1200.155 cannot be directly upgraded with patch 1.
 
Resolution

1) Download 9.6 SP2 from SecureCare Online. The version that is posted is 9.6.1200.156.
2) Stop all DLP Services that are running on the Enterprise Manager host. These services will be grouped together and are named "RSA DLP <component>"
3) Upgrade the Enterprise Manager with SP2 using the following command line if you are NOT using the partner interop service (Cisco ESA integration):
      <Installer.exe> /V"IGNORE_ERRORS=1 IS_NET_API_LOGON_USERNAME=<dlp_service_user> IS_NET_API_LOGON_PASSWORD=<dlp_service_password> IS_SQLSERVER_SERVER=<database_server_name>
      IS_SQLSERVER_DB=<DLP_database_name>"
Example:


"RSA DLP Installer Update 9.6-Sp2.exe" /V"IGNORE_ERRORS=1 IS_NET_API_LOGON_USERNAME=mycorp\DLP_service IS_NET_API_LOGON_PASSWORD=Password1 IS_SQLSERVER_SERVER=MYCORP_SQL IS_SQLSERVER_DB=RSA_DLP_EM"


Upgrade the Enterprise Manager with SP2 using the following command line if you are using the partner interop service (Cisco ESA integration):
      <Installer.exe> /V"IGNORE_ERRORS=1 IS_NET_API_LOGON_USERNAME=<dlp_service_user> IS_NET_API_LOGON_PASSWORD=<dlp_service_password> IS_SQLSERVER_SERVER=<database_server_name>
      IS_SQLSERVER_DB=<DLP_database_name> PARTNER=1"
4) Then proceed to apply patch 1 to the Enterprise Manager and continue with applying patch 1 on other components following instructions in patch 1 release notes. It is not necessary to reapply SP2 to other components.

WorkaroundThere are 2 builds of 9.6 SP2 9.6.1200.155 and 9.6.1200.156 and only 9.6.1200.156 can be upgraded with patch 1. You will only be affected with this issue if you are on the earlier build of 9.6 SP2 (9.6.1200.155) and only the Enterprise Manager component is affected.
 
Notes

To verify the build, see Window?s Control Panel->Program and Features.


Example:

Legacy Article IDa67542

Attachments

    Outcomes