000016418 - Package error with rabbitmq-server-3.3.4-1.noarch when upgrading to RSA Security Analytics 10.4

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000016418
Applies ToRSA Security Analytics
RSA Security Analytics 10.4
RabbitMQ Server
IssuePackage error with rabbitmq-server-3.3.4-1.noarch when upgrading to RSA Security Analytics 10.4.

Attempting to upgrade to RSA Security Analytics 10.4 results in the following error:



Error: Package: rabbitmq-server-3.3.4-1.noarch (sa)
Requires: erlang >= R13B-03
Available: erlang-R16B03-0.2.el6.x86_64 (sa)
erlang = R16B03-0.2.el6
Available: nw-erlang-R15B-2.x86_64 (sa)
erlang



The erlang-R15B package exists in /var/netwitness/srv/www/rsa/updates/RemoteRPMs while multiple erlang-R16B03 packages exist in /var/netwitness/srv/www/rsa/updates/SAUserUploaded.
CauseThis issue occurs because, in order to successfully upgrade to RSA Security Analytics 10.4, all nw-erlang packages must be deleted before the upgrade is attempted.
Resolution

In order to upgrade successfully from RSA Security Analytics 10.3.x to RSA Security Analytics 10.4, the following commands should be executed to remove the nw-erlang package prior to commencing the upgrade.


  1. cd /var/netwitness/srv/www/rsa/updates/RemoteRPMs
  2. rm nw-erlang*
  3. cd /var/netwitness/srv/www/rsa/updates
  4. createrepo .

NOTE:  Make sure that a space is inserted in step 4 between createrepo and .


 


If you are unsure of any of the steps above or experience any issues, contact RSA Support and quote this article ID for further assistance.

Legacy Article IDa67881

Attachments

    Outcomes