000033122 - Error message "Unable to save session state" is displayed after logging in to the RSA Archer Platform

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support on Jun 15, 2018
Version 6Show Document
  • View in full screen mode

Article Content

Article Number000033122
Applies ToRSA Product Set: Archer
RSA Product/Service Type: User Interface, Platform, Archer Control Panel
RSA Version/Condition: 6.x
Platform:  IIS
IssueWhen logging into Archer 6.x Platform, you receive this error.

Unable to save session state.


User-added image
CauseThis issue occurs due to a misconfiguration with SSL and/or the web.config file. 

It may also occur because the web server does not have HTTP Activation enabled or because the session has timed out and you are attempting to return to your Home / Landing screen.
Resolution

Verify that the web.config fie is properly configured.



  1. Edit the C:\inetpub\wwwroot\RSAarcher\web.config file.  (The volume letter may vary.)
  2. Search for the httpGetEnabled attribute and change it from <serviceMetadata httpGetEnabled="false" /> to be <serviceMetadata httpsGetEnabled="true" /> instead.
  3. Search for <security mode="Transport" /> and uncomment it.
  4. Search for <httpTransport maxReceivedMessageSize and change it from <httpTransport maxReceivedMessageSize to be <httpsTransport maxReceivedMessageSize instead.
  5. Search for <httpTransport transferMode="StreamedRequest" and change it from <httpTransport transferMode="StreamedRequest" to be <httpsTransport transferMode="StreamedRequest" instead.
 

Verify that the web server has HTTP Activation enabled.



  1. Open the Server Manager.
  2. Select Manage then Add Roles and Features.
  3. Click Next on the "Before you begin" page if it is displayed.
  4. Click Next for Role-based or feature-based installation.
  5. Select the web server and click Next.
  6. Expand Application Server and select Web Server (IIS) Support then hit Next.
  7. Expand .NET Framework 4.5 Features.
    • If WCF Services is not installed then select it and hit Next.  Install the feature making sure you select HTTP Activation.
    • If WCF Services is installed but HTTP Activation is not then select the HTTP Activation box and select Next and then Install.
 

Verify that there are no discrepancies between your web.config file and the configuration of your web server in regards to SSO/SSL.


The web.config file may be configured for non-SSO/SSL but you have SSO or SSL enabled.  Test this by disabling SSO in the RSA Archer Control Panel and ensure that Default Site in IIS is set to Anonymous and not Windows Authentication.  Make sure to revert your web.config file to an Out of the box state since the web.config file "out of box" is configured in a way that SSO/SSL is indeed disabled.
 

Verify that if Windows Authentication is set to "Enabled" that "Extended Protection" is "Off" on the Windows Authentication.



  1. Open IIS Manager.
  2. Expand the server in the left pane.
  3. Expand Sites on the left.
  4. Expand Default Web Site.
  5. Expand the RSA Archer site. (if Applicable)
  6. Double-click on Authentication.
  7. Click on Windows Authentication.
  8. Click Advanced Settings on the right.
  9. Set Extended Protection to Off.
  10. Perform an iisreset in an Administrator command prompt.

User-added image
WorkaroundIn the situation where the session has expired, log off and back in again.  If the problem is still occurring then the issue is likely caused by one of the reasons addressed above.

Attachments

    Outcomes