000033102 - Error : Unsupported OS to patch OS Patching is only available on SLES appliances when patching RSA Via Lifecycle & Governance

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000033102
Applies ToRSA Product Set: RSA Via Lifecycle and Governance 
RSA Product/Service Type: Appliance
RSA Version/Condition: 6.9.1
Platform: JBoss
Platform (Other): Red Hat Linux
O/S Version: RHEL 5
 
IssueWhen trying to run the RSA Via L&G appliance OS and Oracle updater, the following error occurs on an RHEL5 appliance when using an updater that was made for RHEL not SLES .:

Unsupported OS to patch ... OS Patching is only available on SLES appliances.

The installation script shows a slightly different message:
Unsupported OS to patch ... OS Patching is only available on RSA appliances
CauseThere are three reasons for this messaging to display:
  1. The wrong rsaimg_updater installation script is running;
  2. There is more than one rsaimg_updater installation script; or
  3. The rsaimg_updater installation script is in the wrong location.
ResolutionAs root, make sure the current rsaimg_updater is located in the correct directory and all other versions are removed.
  1. While logged in as root, run this command to find all rsaimg_updater scripts:
find  /  -name  rsaimg_updater

  1. Make sure there is a copy of the updater in /etc/init.d:
/etc/init.d/rsaimg_updater

  1. Delete or rename any others files named 'rsaing_updater'
  2. Verify that the file  /etc/init.d/rsaimg_updater   is the correct updated file from the expanded installer and not an older one.  
  3.  If /etc/init.d/rsaimg_updater is not the correct version, retrieve the file from the installer and copy it to /etc/init.d.
 
NotesThis has been seen previously when an older updater had been used.

Attachments

    Outcomes