000030117 - RSA Authentication Manager 8.x services won't start when network interface adapter eth0 is not found

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support on Dec 13, 2019
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000030117
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
Product Description: RSA Authentication Manager
IssueAuthentication Manager Services might not start when network interface adapter eth0 is not found. The server has no IP address or the wrong IP address. Despite the fact that, another adapter such as eth1 eth2 eth3 is found.
CauseThe virtual machine was moved or copied to a different host.  When this happened, and the machine restarted, there was probably a message: 

This virtual machine might have been moved or copied. In order to configure certain management and networking features,
VMWare ESX needs to know if this virtual machine was moved or copied.If you don't know, answer "I copied it".


If I copied it was selected, VMWare changes the MAC address to prevent MAC address duplication on the network, as designed. However, the SuSE Linux OS is looking for the old MAC Address, and assumes this is a different adapter.
ResolutionRevert to the previous host, and make sure that the VM starts properly.  When moving again, choose the response option for moving it.
WorkaroundChange the network configuration, to assign the new MAC to eth0. 
  • Rename the two files /etc/sysconfig/network/ifcfg-eth0 and /etc/sysconfig/network/ifroute-eth0

    sudo mv /etc/sysconfig/network/ifcfg-eth0 /etc/sysconfig/network/ifcfg-eth0.backup
    sudo mv /etc/sysconfig/network/ifroute-eth0 /etc/sysconfig/network/ifroute-eth0.backup

  • Change the names of the files of the new adapter created (for example, eth1) to be eth0

    sudo mv /etc/sysconfig/network/ifcfg-eth1 /etc/sysconfig/network/ifcfg-eth0
    sudo mv /etc/sysconfig/network/ifroute-eth1 /etc/sysconfig/network/ifroute-eth0

  • Edit the file /etc/sysconfig/network/routes and change all references to eth1 to be eth0
  • Restart the network service

    sudo service network restart

  • Restart Authentication Manager services

    /opt/rsa/am/server/rsaserv restart all

Attachments

    Outcomes