000032873 - Tips for troubleshooting Advanced Workflow in RSA Archer 6.0

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 22, 2017
Version 4Show Document
  • View in full screen mode

Article Content

Article Number000032873
Applies ToRSA Product Set: Archer
RSA Product/Service Type: Advanced Workflow
RSA Version/Condition: 6.0  (This article does not apply to version 6.1.)
 
IssueThe advanced workflow service was not able to start, or have intermittent issues in starting the service. 
An error "Advanced Workflow service. is unavailable" is often observed when you access Workflow Process Designer.
To login to advanced workflow manager, go to administration -> application builder-> application -> select your application -> Advanced Workflow
User-added image
CauseWhile we do not have the root cause of this issue at this stage, there are few configurations settings that we can check for the cause of the problems. Please see "Resolution".
Starting with RSA Archer 6.1, the Advanced Workflow feature changed from from the java version to a .NET version.
ResolutionPlease check the following in attempt to resolve the issue.
1)JAVA_HOME variable is correct
a. Go to my computer -> right click and select properties -> advanced system settings -> environment variables 
b. Check the system variables and see if the variable JAVA_HOME exists
c. If it is exists, check if it is assigned to the JRE 8 folder, e.g: C:\Program Files\Java\jre1.8.0_66\
d. Verify on the folder location shown in (c), whether it contains the bin folder, and whether the bin folder contains java.exe and java.dll
e. If there are changes required on the JAVA_HOME variable, restart the RSA Advanced Workflow service to take effect

2) Wildfly (aka Jboss) has deployed
a. Go to C:\Program Files\RSA Archer\Workflow\jboss-as\standalone\deployments folder
b. Ensure the presence of wp-architect-java.war and wpServices.ear
3) SQL Server has Force Encryption disabled
a. Go to SQL server -> Open SQL Server Configuration Manager
b. Go to SQL Server Network Configuration -> Protocols for MSSQLSERVER
c. Right click and select properties
d. Check "Force Encryption" is set to No
f. Open SQL Management studio and login
g. Locate the instance database and right click to select properties
h. go to options on the navigation menu, then go to the state section
i. Ensure Encryption Enabled is set to False.
-Yes Force Encryption is disabled both at the SQL Native Client and SQL Server level.
4) IIS URL Rewrite is configured
a. Go to IIS Manager
b. Locate the server on the navigation menu
c. select "URL Rewrite" on the home menu
d. Ensure an URL Rewrite rule is present, by default the name of the rule is "RSAArcherAdvancedWorkflowRule"
e. Ensure the Rule has following settings:
User-added image

5) Root application on IIS is using the same ApplicationPool as the RSAArcher application
a. Open IIS manager -> navigate to the "Default Web site"
b. Select "Basic Settings" on the right hand pane
c. On the Application pool, ensure it is using the same pool with RSA Archer Application 
d. Restart the application pool to ensure changes taken effect
Should these don't help to resolve problems, you might escalate the issues to RSA Support with the following information:
Workflow xml files  - Located as Archer.ArcherTech.Services.WorkflowService.xxxxxxxx in c:\program files\rsa archer\logs
Workflow logs - Located at workflow folder, such as c:\program files\rsa archer\logs\workflow
Archer Instance Report - Obtained from Archer Control Panel
Archer Installation Report - Obtained from Archer Control Panel

Attachments

    Outcomes