000032564 - RSA enVision throws error org.apache.tomcat.util.digester.Digester:SEVERE: Parse Fatal Error

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000032564
Applies ToRSA Product Set: enVision
RSA Product/Service Type: enVision Core
RSA Version/Condition: 4.1
Platform: Windows Server 2003/2008 R2
 
Issue
  • NIC Webserver service is showing as started in services.msc, however the GUI is not responding.
  • This is causing the commenting/uncommenting logic of http connector code in server.xml(when switching between http and https using Communication Configuration tool) in HttpConf.java to fail. 
     
CauseThis is happening due to the following error in the server.xml file, located in either E:\nic\4100\site-name_ES\conf for the ES appliance or E:\nic\4100\site-name\conf [on Asrv node] on an LS appliance:
Feb 12, 2016 11:31:08 AM org.apache.tomcat.util.digester.Digester:SEVERE: Parse Fatal Error at line 87 column -1: Next character must be ">" terminating comment .
org.xml.sax.SAXParseException: Next character must be ">" terminating comment.

 
Resolution1.  Open the server.xml file.
2.  On line 87 find the following text:
{code} 
<!-- Define a non-SSL HTTP/1.1 Connector on port 8080--> 
<!--Http-Connector-starts.DO NOT DELETE, MOVE THIS COMMENT. Do not add new line after this line --> <!-- 
<Connector port="${envision.http.port}" maxHttpHeaderSize="8192" protocol="HTTP/1.1" 
maxThreads="150" minSpareThreads="25" maxSpareThreads="75" 
enableLookups="false" redirectPort="${envision.https.port}" acceptCount="100" server=" " 
connectionTimeout="20000" disableUploadTimeout="true" maxPostSize="${envision.http.maxPostSize}" /> 
--> <!-- Http-Connector-ends. DO NOT DELETE, MOVE THIS COMMENT. Do not add new line before this line --> 
<!-- Note : To disable connection timeouts, set connectionTimeout value 
to 0 --> 
{code}

3.  Change this text to:
{code} 
<!-- Define a non-SSL HTTP/1.1 Connector on port 8080--> 
<!--Http-Connector-starts.DO NOT DELETE, MOVE THIS COMMENT. Do not add new line after this line --> 
<!-- 
<Connector port="${envision.http.port}" maxHttpHeaderSize="8192" protocol="HTTP/1.1" 
maxThreads="150" minSpareThreads="25" maxSpareThreads="75" 
enableLookups="false" redirectPort="${envision.https.port}" acceptCount="100" server=" " 
connectionTimeout="20000" disableUploadTimeout="true" maxPostSize="${envision.http.maxPostSize}" /> 
--> 
<!-- Http-Connector-ends. DO NOT DELETE, MOVE THIS COMMENT. Do not add new line before this line --> 
<!-- Note : To disable connection timeouts, set connectionTimeout value 
to 0 --> 
{code}

Attachments

    Outcomes