000031535 - ConsoleServer returns "The SQL Server Service Broker for the current database is not enabled" in RSA ECAT 4.0

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000031535
Applies ToRSA Product Set: ECAT
RSA Product/Service Type: ECAT Server, MS SQL

RSA Version/Condition: 4.x
IssueWhen trying to start ConsoleServer.exe, the following error is returned:
User-added image
CauseThe SQL Server Service Broker for the current database is not enabled, and as a result query notifications are not supported. 
This issue may be noticed after a product upgrade.
ResolutionRun the following query in MS SQL Server Management Studio:
ALTER DATABASE [TYPE_DB_NAME_HERE] SET ENABLE_BROKER WITH ROLLBACK IMMEDIATE 
e.g. ALTER DATABASE ECAT$PRIMARY SET ENABLE_BROKER WITH ROLLBACK IMMEDIATE 
User-added image
In MS SQL 2012 you can do also Properties-> Options -> Service Broker
ALTER DATABASE [TYPE_DB_NAME_HERE] SET ENABLE_BROKER WITH ROLLBACK IMMEDIATE
e.g. ALTER DATABASE ECAT$PRIMARY SET ENABLE_BROKER WITH ROLLBACK IMMEDIATE

Attachments

    Outcomes