000032412 - RSA Security Analytics displays Update Error after a host is upgraded from 10.4.1.x to 10.5.1

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 11Show Document
  • View in full screen mode

Article Content

Article Number000032412
Applies ToRSA Product Set: Security Analytics
RSA Product/Service Type: Core Appliance, Security Analytics Server, Security Analytics UI
RSA Version/Condition: 10.5.1.0
Platform: CentOS
O/S Version: 6
 
IssueAfter upgrading Security Analytics hosts from 10.4.x to 10.5.1, the hosts show Update Error under the Update column in Administration -> Hosts page.
Clicking on the Update Error icon pops up a window with the following error.
"Execution of '/usr/bin/yum -d 0 -e 0 -y list rsa-sa-gpg-pubkeys-10.5.0.0.2982-1.el6.noarch' returned 1: Error: No matching Packages to list","sender":"xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx","agent":"package"
User-added image
CauseThis error occurs if a Security Analytics host is upgraded from 10.4.1.x to 10.5.1 directly which is supported. 
The supported update paths to SA 10.5.1 are:
  • 10.4.1.x to 10.5.1
  • 10.5.0.x to 10.5.1
As SA 10.5.0 upgrade package contains "rsa-sa-gpg-pubkeys-10.5.0.0.2982-1.el6.noarch.rpm", if 10.5.0 is not taken as an upgrade path, this error can occur.
 
WorkaroundTo workaround this error, manually update "rsa-sa-gpg-pubkeys-10.5.0.0.2982-1.el6.noarch.rpm" to the SA repository by following the steps in the Security Analytics 10.5 User Guide.

Once the rpm has been uploaded, go to Administration -> Hosts and check the boxes for the affected hosts and click on Check Updates in the Update button (User-added image) in the menu bar. 

Attachments

    Outcomes