000031860 - SSH Connector not working with special characters in RSA IMG 6.9.1 P04

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000031860
Applies ToRSA Product Set: Identity Management and Governance (IMG)
RSA Version/Condition:  6.9.1 patch 04 and lower
IssueConfigured an SSH connector to provision to an application Virtual Roster, the connector works fine as long as the groups names do not have a '&' or other special characters in it.
It appears as though IMG is passing the values correctly to AFX, but AFX is unable to process them.
The error message below is reported.
 
Cause:
org.mule.api.transformer.TransformerMessagingException: java.lang.Exception: Bad SSH XML configuration: org.xml.sax.SAXParseException: The entity name must immediately follow the '&' in the entity reference. (java.script.ScriptException). Message payload is of type: String

 

User-added image
CauseInput with special characters & or < or > in command as well as parameters was not working in 6.9.1.
Ideally it should work when the endpoint itself allows this command to run with special characters as input.
However this is an exception with Linux endpoints. For Linux endpoints, input parameters have to be escaped with \ as the endpoint itself will not accept the input with special characters in it without the escape character.
ResolutionThis issue has been resolved in RSA IMG 6.9.1 P05.

Attachments

    Outcomes