000027922 - KB-1576 How to correct problems importing database after applying hotfix HF04 for ACM Version 5.0.1

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
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Article Number000027922
Applies ToAffected Versions: 5.0.1
Issue

After applying HF04 to a ACM V5.0.1 environment, and attempting to import a previously created database .dmp file, using the AVDB_Import_AVUSER.sh script, the script fails with these errors. After this failure, its not possible to re-import or use the existing ACM scripts to correct the schema. It's not possible to login or use the create schema.scripts to fix this.


$ ./AVDB_Import_AVUSER.sh -t _ACME_501_test


 


ORACLE_SID=AVDB
ORACLE_CONNECTION_ID=AVDB
ORACLE_SERVICE_NAME=AVDB
AVEKSA_HOME=/home/oracle
AVEKSA_USER=avuser
SYS_USER=sys
DEFAULT_TABLESPACE=DATA_1M
TEMP_TABLESPACE=TEMP


************************************************************************
Wed Apr 11 15:44:14 EDT 2012


Importing from the AVDB Database . . .


IMPORT Input File Dir: /home/oracle/AveksaExportImportDir
IMPORT Input File Name: Export_AVDB_avuser_ACME_501_test.dmp
IMPORT Job Name: AVDB_Import_AVUSER.job
Schema Owner: avuser
PAR File: /home/oracle/database/DBA/AVDB/export/Import_AVDB_avuser.par
LOG File: Import_AVDB_avuser.log
Connect as: avuser/secret@AVDB
Run Date: 20120411


************************************************************************
Wed Apr 11 15:44:14 EDT 2012


=============================================================================
*** ***
*** ***
*** WARNING !!!! Database User avuser will be DELETED !!! ***
*** ***
*** Enter ^C with 30 seconds to cancel . . . ***
*** ***
*** ***
*** Also ensure that the server process is not running and that there ***
*** are no outstanding/remote database connections open through user ***
*** avuser ***
*** ***
=============================================================================


Wed Apr 11 15:44:44 EDT 2012
=============================================================================
Dropping and ReCreating the avuser user . . .


Dropping User . . .


SQL*Plus: Release 11.2.0.2.0 Production on Wed Apr 11 15:44:44 2012


Copyright (c) 1982, 2010, Oracle. All rights reserved.



Connected to:
Oracle Database 11g Release 11.2.0.2.0 - 64bit Production
With the Automatic Storage Management option


SQL> SQL> SQL> SQL> SQL> SQL> 2 3 4 5 6
MSG
--------------------------------------------------------------------------------
*******************************************************************************
Connected to database instance on host vm-support-28
Scripts being run as database user SYS@AVDB
Execution start time 04/11/2012 15:44:44
*******************************************************************************



SQL> SQL> SQL> 2 3 4 5 6 7 8 9 10 11 12 13 The user "avuser" doesn't exist! Ignoring the drop user.


PL/SQL procedure successfully completed.


SQL> No errors.
SQL> SQL> SQL> Disconnected from Oracle Database 11g Release 11.2.0.2.0 - 64bit Production
With the Automatic Storage Management option
Creating User . . .


SQL*Plus: Release 11.2.0.2.0 Production on Wed Apr 11 15:44:44 2012


Copyright (c) 1982, 2010, Oracle. All rights reserved.



Connected to:
Oracle Database 11g Release 11.2.0.2.0 - 64bit Production
With the Automatic Storage Management option


SQL> SQL> SQL> SQL> SQL> SQL> SQL> SQL> SQL> SP2-0606: Cannot create SPOOL file "log/Create_User.log"
SQL> SQL> Create USER avuser identified by secret profile ACMPROFILE
*
ERROR at line 1:
ORA-02380: profile ACMPROFILE does not exist



Elapsed: 00:00:00.00
SQL> SQL> alter user avuser default tablespace DATA_1M
*
ERROR at line 1:
ORA-01918: user 'AVUSER' does not exist



Elapsed: 00:00:00.01
SQL> alter user avuser temporary tablespace TEMP
*
ERROR at line 1:
ORA-01918: user 'AVUSER' does not exist



Elapsed: 00:00:00.00
SQL> SQL> grant unlimited tablespace to avuser
*
ERROR at line 1:
ORA-01917: user or role 'AVUSER' does not exist

Cause

The problem is due to the addition of a ACM specific profile reference to the AVDB_Import_AVUSER.sh script. This new ACM Oracle AVUSER profile was added to the ACM Oracle 11g database. This profile was added to ensure that a new security feature added to Oracle 11g would not cause unexpected account lockouts for the ACM user. (Refer to KB-1563 for more information on the specifics on the Oracle 11g account security feature.) This profile does not exist in baseline ACM 5.0.1, but is referenced in the HF04 import script.


Resolution

This problem is known to occur with ACM V5.0.1 HF04 and will be corrected in later 5.0.1 hotfixes. Other ACM versions may show similar behaviour, and the corrective action would be the same.

Workaround

If this error occurs, it can be 'worked' around by executing the following SQL as sysdba before doing any other actions. Once this SQL is successfully executed, the import can be re-run and it should succeed.


 


$ sqlplus "/as sysdba"


SQL> Create Profile ACMPROFILE LIMIT PASSWORD_LIFE_TIME UNLIMITED;
SQL> Create USER AVUSER identified by secret;
SQL> alter user AVUSER profile ACMPROFILE;


 


 


Once the ACMPROFILE is created, it does not need to be created again, unless a brand new schema is created.

NotesThis is not a problem on systems using remote database, since the AVDB_Import_AVUSER.sh script is not used to import a database .dmp file on a remote database system.

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