000030610 - Access Manager 5.0 Agent - Manually removing the cleartrust module caused a misconfiguration in IIS web.config file

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000030610
Applies ToRSA Product Set: ClearTrust
RSA Product/Service Type: Web Agent IIS
RSA Version/Condition: V5.0
Platform: Windows
Platform (Other): null
O/S Version: 2008 Server R2 Enterprise (64 bit)
Product Name: null
Product Description: null
IssueWe are seeing an issue while integrating application with AxM 5.0 agent. The installation is not working and also the logs are also not getting generated.
CauseManually removing and adding the cleartrust module during troubleshooting cause the following issue in the web.config file of the sites document root directory
The following <modules> tag gets entered when the module is removed at the site level
<modules>
            <remove name="ClearTrust" />
</modules>
When manually adding the module back in, instead of removing the above tag, a new line is added so that the the <modules> tag looks as follows:
<modules>
            <remove name="ClearTrust" />
            <add name="ClearTrust" preCondition="bitness32" />
</modules>
When the 64 bit agent was re-installed the above <modules> tag was left in place causing the site to look for the 32 bit module, when 64 bit was installed.
 
ResolutionManually reconfigure the following line to match the bitness of the module that is configured, in this case we changed it to "bitness64"
<add name="ClearTrust" preCondition="bitness64" />
Once the above parameter is set to match the bitness of the module being used, the agent should start
NotesRSA does not recommend manually removing the cleartrust module and if it has to be done it should be done by an administrator familiar with the workings of the IIS webserver or in coordination with RSA Technical Support

Attachments

    Outcomes