000030886 - Performance problems loading iViews in RSA Archer

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000030886
Applies ToRSA Product Set: Archer
RSA Version/Condition: Any Version
IssueiView reports take a long time to load when displaying a workspace.  An "unexpected error" message may be displayed.
CausePerformance problems could be due to undersizing or misconfiguration of the environment. Or, a specific problem could exist on either the web or database server.
ResolutionIf performance of the Archer site is a ongoing problem, see the "RSA Archer Sizing and Performance Guide" for general guidance.
Aside from general performance considerations, a specific problem might exist on either the web server or database server. 
Check the archer.w3wp logs for the date of the problem. You may see errors such as below, indicating a time out on the web server.:
<Description>Request timed out.</Description>
                    <AppDomain>/LM/W3SVC/1/ROOT-1-130830151895058409</AppDomain>
                    <ContextData>
                        <BaseUrl>http://grc.emc.com/SearchContent/IViewSearchResults.aspx</BaseUrl>
                        <view>Report</view>
                        <Report>ReportId: 12275, ReportName: Incident Queue- New Incidents, ReportType: SearchBased</Report>
                        <Dashboard>DashboardId: 447, DashboardName: CIRTian's HUD, IsActive: True, IsPersonal: False, IsPrivate: True</Dashboard>
                        <allowScrolling>true</allowScrolling>
                        <CacheStatus>invalid</CacheStatus>
                        <fw>1434</fw>
                        <fh>267</fh>
                    </ContextData>
                    <Exception>
                        <ExceptionType>System.Web.HttpException, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a</ExceptionType>
                        <Message>Request timed out.</Message>

Troubleshooting steps - Web server:
  1. Increase the executionTimeout setting on the web server:
- Highlight the Archer website (or default web site, as the case may be)

- Click Configuration Editor in the center pane.
- In the "Section" dropdown, select "system.web/httpRuntime"
- Find the "executionTimeout" parameter. Set it to "00:05:00" (five minutes)
- Open a command prompt with "Run as administrator" and issue the command IISRESET
 

  1. Reboot the web server.
Troubleshooting steps - Database server
If the above steps do not fix the problem, the timeout could be originating on the database server.  You may see errors in the archer.w3wp log such as below:

<Message>Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
SQL statement: usp_search_filter_values_list_not_equal
 

 

What you can do:
 

  1. Ensure that SQL Server Agent jobs have been set up to periodically reindex and update statistics for the Archer instance database.  See KB Article 000030702 for instructions on setting these up.
 
  1. Run a SQL Profiler trace to identify stored procedures that are taking more than one second to execute.  In particular, you may see stored procedure related to report execution, such as the one in the error message above, "usp_search_filter_values_list_not_equal"
 
  1. Try recompiling the stored procedure referenced in the error with the following SQL command:  exec sp_recompile 'usp_[procname]'
     

Attachments

    Outcomes