000013179 - Unable to start the aserver from the command line in debug mode  'java.lang.NumberFormatException: For input string: '0:0:0:0:0:0:1'

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 22, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000013179
Applies ToWindows 2008
RSA Access Manger 6.1
Operating system supports IPV6
IssueUnable to start the aserver from the command line in debug mode, "java.lang.NumberFormatException: For input string: "0:0:0:0:0:0:1"
Resolution

IPV6 must be disabled, as AxM does not currently support ipv6. 

To disable ipv6, do the following:

1) Uncheck IPv6 in the the network interface setting

2) Add DisabledComponents setting in the
registry at HKLM\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters

3) comment out or alternately remove the ::1 localhost entry in the c:\windows\system32\drivers\etc\hosts file


In the event you continue to have issues running the aserver (or any of the AxM components) in debug mode and are recieving this error, the following workaround may be used:

1) In aserver/dispatcher/eserver.bats under the "init" section, include on the JVM_OSARGS line the following directive, -Djava.net.preferIPv4Stack=true.

Example:

:init
set JAVA_HOME=%AXM_HOME%\jre
set JVM_OSARGS=-server -Djava.net.preferIPv4Stack=true
set JVM_64=0

2) in hosts file, in addition to removing the v6 loopback, add the IPV4 ip address and fqdn of the host (it is not there by default), insuring it matches the primary hostname

 

Legacy Article IDa55728

Attachments

    Outcomes