000012060 - Cannot connect to concentrator source after upgrade RSA Informer to version 2.0.5.6

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000012060
Applies ToRSA NetWitness NextGen
RSA NetWitness Informer
RSA NetWitness Informer 2.0.5.6
IssueCannot connect to concentrator source after upgrade RSA Informer  to version 2.0.5.6.

After upgrade to 2.0.5.6 Informer, cannot connect to concentrator/broker source in Informer webUI, see this error in Informer log:

2013-01-14 09:31:29.4704 (HandleWatcher) Connection check failed because an invalid argument was supplied ... the engine will try to reconnect until a valid connection to a NetWitness data source is made.

CauseOne cause for this issue is that the previous version is not removed properly during upgrade. One can confirm this by restart informer service, and then review Informer log:
If log shows Informer engine 2.0.5.2 or other version that is not 2.0.5.6 as one sees in Informer webUI, then this is the problem.
ResolutionHere are steps to fix this issue:
1. Stop informer service;
2. Go to control panel, add/remove programs, and remove Informer service;
3. Start a command prompt, and enter command below, after hitting enter, you should see Success message:
sc delete "NetWitness Informer Service"
4. Re-install informer 2.0.5.6;
5. Restart informer service; check Informer log and ensure you see informer engine 2.0.5.6 now;
6. Login to Informer webUI, now you should be able to connect to concentrator/broker source now.
Legacy Article IDa60654

Attachments

    Outcomes