000020327 - Which file on the Keon Web PassPort server determines if KWP client needs to be upgraded?

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 22, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000020327
Applies ToKeon Web PassPort 1.1.1
Keon Web PassPort Client
IssueWhich file on the Keon Web PassPort server determines if KWP client needs to be upgraded?
ResolutionThe file \RSA Security\Web PassPort 1.1\Server\Web\Scripts\version.js determines if the end-user's KWP client needs to be upgraded. The variable KPV_CURRENT is configured to be the current version of KWP client software installed on the server for download. If the KWP Server detects the end-user's KWP client does not match this version, they will be redirected to a Web page (pleaseUninstall.htm) showing instructions for upgrading the client.

Here is the code from the version.js file:

####################

//Unknown version
KPV_UNKNOWN   = 0x00000000;
//Keon SecurWEB V1.00
KPV_100      = 0x00010000;
//Keon SecurWEB V1.1
KPV_110      = 0x00010100;
//Keon SecurWEB V1.1 patch 1
//NB: For some reason KWP 1.1 was released with the patch level set
//to 12 and so the real patch 1 must be set to 13.
KPV_110p1    = 0x0001010D;

/*
*    The KPV_CURRENT value below should always reflect the current version of
*    client software installed on the server for download. The installation of
*    a client patch version on the server should include an update of this file
*    with a new value for KPV in order for the client to detect that a newer version
*    of the client is available on the server.
*/
KPV_CURRENT   = KPV_110p1;

####################
Legacy Article IDa15900

Attachments

    Outcomes