000015163 - AxM Agent for Apache 4.X on Solaris 10 - unable to successfully complete ./install.sh in a non-global zone

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000015163
Applies ToAxM Agent 4.7, 4.8 and 4.9
Solaris 10
IssueAxM Agent for Apache 4.X on Solaris 10 - unable to successfully complete ./install.sh in a non-global zone
./install.sh -d . -p ap20 is failing on pkgadd
ResolutionYou must tar -xvf the agent bundle in the global zone, then run the ./install.sh within the global zone.  This restriction is a Sun/Oracle zone restriction for pkgadd.  The install.sh script leverages pkgadd, therefore you must abide by the zone rule as dictated by Sun/Oracle.
Workaroundreference:

http://docs.sun.com/app/docs/doc/817-1592/6mhahup48?a=view

"The pkgadd utility cannot add a package:
    To any subset of the non-global zones
    To all non-global zones, unless the package is already installed in the global zone"
Legacy Article IDa51758

Attachments

    Outcomes