000013503 - AxM- 4.8 Apache agent reports 'Web server config not defined for this virtual host' in ct_agent.log

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000013503
Applies ToClearTrust Web Agent Apache V4.8 Agent
Apache webserver
IssueAxM- 4.8 Apache agent reports "Web server config not defined for this virtual host" in ct_agent.log
ct_agent.log reports:

<Critical> - Web server config is not defined for this virtual host
CauseThe Apache httpd.conf defines multiple virtual hosts.  Each of these virtual hosts are not explicitly defined in the RSA webagent.conf.  There is however a "catch all" virtual block in place by default  When the catch all directive block is removed from the webagent.conf and each virtual host is not called out specifically in the webagent.conf  to match all virtual hosts defined in the httpd.conf, the 4.8 agent will produce this error and log this alert.

You should not remove the virtual host catch-all from any webagent.conf files.  When a virtual host is not explicitly defined with its own virtual host block section in webagent.conf (typically, virtual hosts definitions are placed at the bottom of the webagent.conf), the virtual host catch-all will match any virtual host for the AXM protected web server on any address or port, regardless of whether it is specifically defined.

The catch-all is by default at the bottom of the default webagent.conf and starts with:

<VirtualHost name=* address=* port=*>

and terminates with:


To disable the agent for all virtual hosts in webagent.conf that are not specifically defined, make the following change to the catch-all block:

<VirtualHost name=* address=* port=*>

Note: virtual webserver blocks in AXM agent webagent.conf files support many more settings.  Refer to the Installation and Configuration guide or the webagent.conf comments for additional information.


<VirtualHost name=web1.example.com address=* port=*>

<VirtualHost name=web1qa.example.com address=* port=*>

Refer to solution a34308 for additional information on webagent parameter overrides.

Legacy Article IDa41052