000014547 - AxM - HTTPS retention URL contains port 80

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000014547
Applies ToRSA Access Manager Web Server Agent version  V4.7
IBM HTTP Server 6.0 and 7.0   ( Apache 2.2.8  and 2.0.47 ) 
Apache directive,  UseCanonicalName On
IssueAxM - HTTPS retention URL contains port 80
 Hitting an SSL HTTPS site produces a retention url (CT_ORIG_URL) that contains port 80 instead of 443. 
CauseIn the Apache httpd.conf file the ServerName in the VirtualHost block was specified without a port number.
Resolution

Verify that the port number is appended to the ServerName, See example below:

<VirtualHost 192.168.66.43:443>
  ServerName collaborate.example.com:443
  ServerAlias collaborate collaborate-s collaboratetst-s.example.com
  SSLEnable
  SSLClientAuth None
  <Directory "/opt/IBM/HTTPServer/htdocs/collaborate">
     Options Indexes
     AllowOverride None
     order allow,deny
     allow from all
  </Directory>
  DocumentRoot "/opt/IBM/HTTPServer/htdocs/collaborate"
  CustomLog "|/opt/IBM/HTTPServer/bin/rotatelogs /opt/IBM/HTTPServer/logs/collaborate_access_%m-%d-%Y 86400" combined env=!dontLog
</VirtualHost>

<VirtualHost 192.168.66.43:80>
  ServerName collaborate.example.com:80
  ServerAlias collaborate collaborate-s collaborate-s.example.com
  DocumentRoot "/opt/IBM/HTTPServer/htdocs/collaborate"
  CustomLog "|/opt/IBM/HTTPServer/bin/rotatelogs /opt/IBM/HTTPServer/logs/collaborate_access_%m-%d-%Y 86400" combined env=!dontLog
</VirtualHost>

 

Legacy Article IDa46542

Attachments

    Outcomes