000022719 - Apache fails to start with RSA Authentication Agent. Apache error log shows 'DSO load failed: /etc/httpd/rsawebagent/librsawa_apache.so'.

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000022719
Applies ToApache 2.0.52
Red Hat Linux 3.0
RSA Authentication Agent 5.3 for Web (Apache)
IssueApache fails to start with RSA Authentication Agent. Apache error log shows "DSO load failed: /etc/httpd/rsawebagent/librsawa_apache.so".
DSO load failed:/etc/httpd/rsawebagent/librsawa_apache.so
CauseIf you run the ldd command on the /etc/httpd/rsawebagent/librsawe_apache.so, note that one of the libraries is missing:

# ldd librsawa_apache.so

libstdc++.so.5 => not found

libm.so.6 => /lib/tls/libm.so.6 (0x00111000)

libc.so.6 => /lib/tls/libc.so.6 (0x00c82000)

libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00bec000)

/lib/ld-linux.so.2 (0x00472000)
Resolution

To correct this issue, install the following libraries on the Red Hat Linux 3.0 or 4.0 machine:

Compat-glibc-7.x-2.2.4.32.6

Compat-libstdc++-7.3-2.96.128

Note that these version numbers may be slightly different depending on the exact OS/Update level you are running.

These RPMS can be installed by using the "Add/Remove Applications" GUI by installing the "Legacy Software Development" packages. 

Legacy Article IDa30006

Attachments

    Outcomes