000015569 - AM 7.1sp3 and APP 3.0sp3: new sp3 functionality  'disable-pwd-prompt' on manage-backups utility doesn't seem to work

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000015569
Applies ToAppliance 3.0.X
Authentication Manager 7.1 SP3, All OS, All platforms
Issue

AM 7.1sp3 and APP 3.0sp3: new sp3 functionality, "disable-pwd-prompt" on manage-backups utility doesn't seem to work


When trying to take a backup from the command line using the manage-backups CLU with the new option introduced in sp3 to disable password prompt via the flag disable-pwd-prompt, you still get prompted for the RSA master password, example:

Windows:

D:\Program Files\RSA Security\RSA Authentication Manager\utils>rsautil.cmd manage-backups --action export -f d:\Backup\RSAbackup.dmp -t --action disable-pwd-prompt

Enter master password:

Unix (all) and APP 3.0 (as rsaadmin on APP 3.0, as the user AM 7.1 runs under all other unix)

cd /usr/local/RSASecurity/RSAAuthenticationManager/utils

./rsautil manage-backups --action export -f /var/tmp/backups/backup.dmp -t --action disable-pwd-prompt

Enter master password:

 

Resolution

Before attempting to run a backup without being prompted for a password, you will run a separate manage-backups command with the new flag.  This command need only be run once to disable password prompting.  The command to run first: 

rsautil manage-backups -a disable-pwd-prompt

Enter master password: ********

 Once this command is executed, you will no longer be prompted for a password, therefore execute the following syntax to capture a backup 

Windows:

rsautil manage-backups --action export -f d:\Backup\RSAbackup 

Unix/App 3.0

./rsautil manage-backups --action export -f /var/tmp/backups/RSABackup.dmp

Notes

Note on Unix/APP 3.0 - You MUST specify a file extension to your backup file name, else the command will fail to execute, example: 

./rsautil manage-backups -a export -f /var/tmp/backups/RSABackup
Operation started : WED APR 28 15:25:02 EDT 2010
Operation failed : The file extension does not exist: /var/tmp/backups/RSBackup
Operation completed : WED APR 28 15:25:03 EDT 2010

You must specify a file extension on the backup file name, example:

bash-3.00$ ./rsautil manage-backups -a export -f /var/tmp/backups/RSABackup.dmp
Operation started : WED APR 28 15:28:59 EDT 2010
Exporting the user credentials
Exporting the database
Operation completed : WED APR 28 15:30:20 EDT 2010


 

 

Legacy Article IDa50767

Attachments

    Outcomes