000011671 - Securid Securid Apache Agent 7.0 for Linux  error on startup: mod_rsawa_apache.so: failed to map segment from shared object: Permission denied

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000011671
Applies ToRedhat 5
Apache Agent 7.0 for Securid
IssueSecurid Apache Agent 7.0 for Linux, error on startup: mod_rsawa_apache.so: failed to map segment from shared object: Permission denied
After installing the RSA Securid Agent 7.0 for RedHat 5, Apache will no longer start and the following error is displayed:

httpd: Syntax error on line 996 of /usr/local/apache2/conf/httpd.conf: Syntax error on line 6 of /usr/local/apache2/rsawebagent/rsawebagent.conf: Cannot load /usr/local/apache2/rsawebagent/mod_rsawa_apache.so into server: /usr/local/apache2/rsawebagent/mod_rsawa_apache.so: failed to map segment from shared object: Permission denied
CauseSELinux has been enabled in RH5, and is too restrictive to allow the rsa webagent to load.
ResolutionTo diagnose if SELinux policies are the root cause, perform the following to temporarily disable SELinux in the current shell as root:
echo 0 >/selinux/enforce

Then restart apache:

/usr/sbin/apachectl start

If apache now starts, you will need to modify your SElinux policy to allow optional apache .so modules to load.

NotesFor information on configuring SELinux to allow Apache to load the rsa module, visit:
http://www.redhat.com/magazine/006apr05/features/selinux

Or, contact RedHat directly for OS configuration assistance.

SELinux, while desirable as an OS security feature on RedHat, is not a required component for interoperatibility with the RSA webagent.
Legacy Article IDa55146

Attachments

    Outcomes