000016325 - AM 7.1sp4 full kit for RHEL 5.5 64 bit fails to install with error 'Failed to create database listener'

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000016325
Applies ToAuthentication Manager 7.1 SP4 full kit for RHEL 5.5 or higher 64 bit
Red Hat Enterprise Linux 5.5 (64-bit)
IssueAM 7.1sp4 full kit for RHEL 5.5 64 bit fails to install with error "Failed to create database listener"

/usr/local/RSASecurity/RSAAuthenticationManager/install/logs/config/config_trace.log throwing the following error:

30 Jul 07:40:57.771 INFO - Main Thread - config.ConfigEngine - Command Output Property Keys (CreateDatabaseListener): {}
30 Jul 07:40:58.004 ERROR - Main Thread - config.ConfigUtil - Failed configuration command execution
com.rsa.installfwrk.config.exception.ConfigurationException: Failed configuration command execution
 at com.rsa.installfwrk.config.ConfigEngine.execute(ConfigEngine.java:223)
 at com.rsa.installfwrk.config.ConfigUtil.runConfig(ConfigUtil.java:53)
 at com.rsa.installfwrk.config.ConfigUtil.main(ConfigUtil.java:35)
Caused by: com.rsa.installfwrk.common.command.exception.CommandException: Failed to create database listener
 at com.rsa.installfwrk.config.command.CreateDBListenerCmd.execute(CreateDBListenerCmd.java:47)
 at com.rsa.installfwrk.config.ConfigEngine.execute(ConfigEngine.java:185)
 ... 2 more

Cause

This error message is does not provide an accurate assessment as to the failure.  Although the AM 7.1 installer passed the system for prequisites as documented on page 20 of the Installation and Configuration guide for AM 7.1, which states:

5.5 (64-bit) Packages (RPM)
The Authentication Manager installer checks to see that the following packages are installed and stops the installation process if any are missing. Make sure that you have these packages installed with the specified version or later.

gcc 4.1.2-48.el5.x86_64
glibc-devel 2.5-49.i386
glibc-devel 2.5-49.x86_64
glibc-headers 2.5.49.x86_64
kernel-headers 2.6.18-194.el5.x86_64
libgomp 4.4.0-6.el5.x86_64
libXp 1.0.0-8.1.el5.i386
libXp 1.0.0-8.1.el5.x86_64

In reality, even when all of these packages are installed, libXtst and libXtst-devel must also be installed, as well as the Motif RPMs.  These are not caught by the installer during the prereq check.

 

 

Resolution

Uninstall the product with the uninstall.sh script out of /usr/local/RSASecurity/RSAAuthenticationManager/uninstall  , and remove any extraneouos directories or files that may be left behind by running afterwards. 

rm -rf /usr/local/RSASecurity

Install the two Xtst packages, libXtst and libXtst-devel package, and all motif packages.

Install the AM7.1 SP4 full kit again.

If the installation fails again, do NOT allow it to finish without collecting logs from a different session, as exiting the installer will clear out some of the logs.  

Notesalso need motif RPMs . See A56016
Legacy Article IDa55645

Attachments

    Outcomes