000011814 - Why does the drop-down list show client versions only up to 2.2 when creating a Client on KMS GUI?

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 22, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000011814
Applies ToRSA Key Manager Server 2.5.x
RSA Key Manager Server 2.7.x
IssueWhy does the drop-down list show client versions only up to 2.2 when creating a Client on KMS GUI?
RSA Key Manager Server administration GUI => Clients tab => click Create => Client Version field shows only the following options:

1.5
2.0
2.1.1
2.1.2
2.1.3
2.2

"Client Version" field on Client create page does not show versions 2.5 and later (even though later versions of RKM Client exist)
ResolutionThis behavior is as designed and not a bug.  Up to version 2.2 Auto Enrollment feature was not available in RKM product and client was supposed to get enrolled manually. The drop-down list is provided for client version to be entered manually for those older versions of clients.  RKM version 2.5 introduced Auto Enrollment as a functionality and client is supposed to get registered itself (through auto-enrollment).
Legacy Article IDa52004

Attachments

    Outcomes