000016227 - Access Manager cannot be started from the services

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000016227
Applies ToAccess Manager 6.1
Microsoft Windows 2008
IssueAccess Manager cannot be started from the services
The installer reports that it failed to run the keygen utility correctly.
Attempting to run the keygen utility manually reports the same error. 
When starting an Access Manager service windows reports the following error:

"Windows could not start the RSAdispatchservice61 on Local Computer"
"error 193:0xc1"

In the registry for the services you can see that the paths to the RSA binaries contain filenames that are not in the 8.3 short name format:
C:\PROGRA~1\RSA\Access Manager Servers 6.1

When starting Access Mangaer from a batch file the following error is reported:
'C:\PROGRA~1\RSA\Access' is not recognized as an internal or external command,
operable program or batch file.
Press any key to continue 
CauseJAVA does not handle unquoted long filenames with spaces for command parameters. RSA Access Manager scripts and services use DOS 8.3 shortnames in commands.   This requires that 8.3 shortname support be enabled on the file system.  The scripts will be unable to launch if the filenames contain spaces.  The default installation directory for RSA Access Manger is "C:\Program Files\RSA\Access Manager Servers 6.1" which contains spaces.  You can check the status of 8.3 support by runing the following command:
fsutil behavior query disable8dot3
a value of 1 means disabled
Note that any 8.3 filenames created before 8.3 support is disabled still remain in place.  This setting only prevents new 8.3 short names from being created.
ResolutionEnable 8.3 filename support with the fsutil utility.
Install RSA Access Manager in a file location that uses filenames less than 8 characters and that does not contains spaces.  For example, during installation select the install directory as:
C:\RSA|AxM\61\
WorkaroundSystem administrator has hardened machine by disabling 8.3 filename support by running:
Fsutil behavior set disable8dot3 1
Legacy Article IDa56034

Attachments

    Outcomes