000030946 - SELinux Does Not Allow Apache and RSA Agent to Run

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000030946
Applies ToRSA Access Manager Apache Agent version 5.0
Apache Webserver
 
IssueInstallation was successful yet httpd deamon won't run
 

CONGRATULATIONS!


RSA Access Manager Agent 5.0 for Apache has been successfully installed to /opt


========================================================================


Next Steps


-----------------


  • Restart the webserver

PRESS <ENTER> TO EXIT THE INSTALLER:


[root@************ axm]# service httpd restart


Stopping httpd: [FAILED]


Starting httpd: httpd: Syntax error on line 1011 of /etc/httpd/conf/httpd.conf: Syntax error on line 9 of /opt/rsa-axm/agent-50-apache/webservers/********/conf/ct-httpd.conf: Cannot load /opt/rsa-axm/agent-50-apache/lib/libct_apache22_agent.so into server: /opt/rsa-axm/agent-50-apache/lib/libct_apache22_agent.so: failed to map segment from shared object: Permission denied

NotesNote:
We have not verified/qualified our agent with SElinux enabled or disabled. The above solution is just for information not sure whether it addresses the issue. 

Attachments

    Outcomes