000015989 - 'Bigger type length than Maximum' error in aa_server.log during startup

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000015989
Applies ToAdaptive Authentication 6.0.2.1 SP3
Apache Tomcat 6.x
Oracle 10+
IssueThe Adaptive Authentication application will not start. Within the aa_server.log, a stack trace appears with a protocol error, and a subsequent error message from the Oracle JDBC driver stating "Bigger type length than Maximum".
CauseThe issue is present when using the 10.1.x versions of the Oracle JDBC driver. In addition, it may be the result of having a driver being used that does not match the Oracle server version.
ResolutionThe fix is to use a later driver version (at the time of this article, the version was 10.2.0.5). In addition, it may be best to match the driver version to the version of the Oracle server version being used.
NotesThe Oracle bug number for this issue is: 4043236. The solution id number is: ORA-17412
Legacy Article IDa53568

Attachments

    Outcomes