000029916 - '-bash: /usr/sbin/sesh: No such file or directory' error when starting RSA Identity Governance & Lifecycle

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support on Jul 20, 2020
Version 4Show Document
  • View in full screen mode

Article Content

Article Number000029916
Applies ToRSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: All
O/S Version: Red Hat Enterprise Linux (RHEL)
 
IssueWhen attempting to start the RSA Identity Governance & Lifecycle database or application, the following error occurs:
 
-bash: /usr/sbin/sesh: No such file or directory


EXAMPLES:

  • Starting the RSA Identity Governance & Lifecycle application:


$ service aveksa_server start
-bash: /usr/sbin/sesh: No such file or directory


--or--



$ acm start
-bash: /usr/sbin/sesh: No such file or directory


  • Starting the RSA Identity Governance & Lifecycle database:


$ service aveksa_server startdb
-bash: /usr/sbin/sesh: No such file or directory


--or--



$ acm startdb
-bash: /usr/sbin/sesh: No such file or directory


 
CauseThis error occurs if Security-Enhanced Linux (SELinux) is enabled on the RedHat host. This issue is most prevalent on software-based installations where RSA has not provided the operating system. On a hardware appliance with Red Hat (older RSA Identity Governance & Lifecycle versions were distributed on Red Hat appliances), SELinux is disabled by default. If this error occurs on an RSA Identity Governance & Lifecycle appliance with Red Hat, the configuration has been modified from the default.
 
ResolutionTo resolve this issue, check to see if SELinux is enabled and if it is, disable it.
  1. Check to see if SELinux is enabled:

Login as root and run the sestatus command to return the current state:
 


User-added image


  1. If SELinux is enabled, disable SELinux:

  1. Backup /etc/selinux/config file:


cp /etc/selinux/config /etc/selinux/config.backup_{date}


  1. Edit the /etc/selinux/config file and make sure that SELINUX=disabled.

User-added image


  1. Reboot the Red Hat server for the change to take effect. 

 

Attachments

    Outcomes