000031011 - DLP : Root Endpoint Coordinator (REPC) is stuck at pending status.

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000031011
IssueThe REPC is showing pending status even after checking all the solutions in the Troubleshooting guide.
Error observed in the epcservice.log

2015-05-20 03:48:30,682 [SystemMonitor -9] ERROR EndpointCoordinator.Communication.RabbitMQ.CommunicationManager - Failed to get connection to localhost
2015-05-20 03:49:31,723 [SystemMonitor -9] ERROR EndpointCoordinator.Communication.RabbitMQ.CommunicationManager - Failed to get connection to localhost
2015-05-20 03:50:32,765 [SystemMonitor -9] ERROR EndpointCoordinator.Communication.RabbitMQ.CommunicationManager - Failed to get connection to localhost
Error in rabbit-mq.log
=ERROR REPORT==== 10-Sep-2014::14:23:28 ===
error on AMQP connection <0.750.0>: {ssl_upgrade_error,
                                     "insufficient security"}
=INFO REPORT==== 10-Sep-2014::14:23:28 ===
accepting AMQP connection <0.755.0> ([::1]:49989 -> [::1]:5671)
=ERROR REPORT==== 10-Sep-2014::14:23:28 ===
SSL: hello: ssl_handshake.erl:156:Fatal error: insufficient security
=ERROR REPORT==== 10-Sep-2014::14:23:28 ===
error on AMQP connection <0.755.0>: {ssl_upgrade_error,
                                     "insufficient security"}
=INFO REPORT==== 10-Sep-2014::14:23:38 ===
accepting AMQP connection <0.760.0> ([::1]:49990 -> [::1]:5671)
=ERROR REPORT==== 10-Sep-2014::14:23:38 ===
SSL: hello: ssl_handshake.erl:156:Fatal error: insufficient security
=ERROR REPORT==== 10-Sep-2014::14:23:38 ===
error on AMQP connection <0.760.0>: {ssl_upgrade_error,
                                     "insufficient security"}
=INFO REPORT==== 10-Sep-2014::14:23:38 ===
accepting AMQP connection <0.765.0> ([::1]:49991 -> [::1]:5671)
=ERROR REPORT==== 10-Sep-2014::14:23:38 ===
SSL: hello: ssl_handshake.erl:156:Fatal error: insufficient security
 
CauseMore ciphers have been added to the SSL but not added to the configuration file in the rabbitmq folder. 
Resolution 
1 - Go the install_dir\EndpointCoordinator\RabbitMQ\AppData\rabbitmq.config
 
 
2 - Replace the configuration with the configuration below.

 
<modified install_dir\EndpointCoordinator\RabbitMQ\AppData\rabbitmq.config> 

{rabbitmq_stomp, [{tcp_listeners, [{"127.0.0.1", 61613}]}, 
{default_user, [{login, "g4ie1pygq0crofaqxdu3lt"}, 
{passcode, "r40iundfxsis5erv0ic5yj"}]}, 
{implicit_connect, true}]}, 
{rabbit, [ {tcp_listeners, []}, 
{ssl_listeners, [5671]}, 
{ssl_options, [{certfile,"D:\\RSA\\ENDPOI~1\\Certificates\\ServerCert.crt"}, 
{keyfile,"D:\\RSA\\ENDPOI~1\\Certificates\\ServerKey.key"}, 
{cacertfile,"D:\\RSA\\ENDPOI~1\\Certificates\\ServerChain.pem"}, 
{ciphers,[ {rsa,rc4_128,sha},{rsa,rc4_128,md5},{dhe_rsa,aes_256_cbc,sha},{dhe_dss,aes_256_cbc,sha},{rsa,aes_256_cbc,sha} ]} 
]} 
]} 
]. 
</modified rabbitmq.config> 
3- restart the REPC service.

Attachments

    Outcomes