000030049 - AM8.x - Unable to configure backups to Windows Shared Folder with an error "Failed to validate remote location"

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support Employee on Apr 21, 2017
Version 2Show Document
  • View in full screen mode

Article Content

Article Number000030049
Applies ToRSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.0/8.1
Platform: SUSE Linux Enterprise
O/S Version: Suse Linux 11 SP3
Product Description: RSA SecurID Appliance
IssueEncountered an error "Failed to validate remote location" when configuring backups from Operations Console
Operations Console > Maintenance > Backup and Restore > Manage Backups > Select Your Backup Location: Windows Shared Folder
System Log showed as below: 
15-04-15 11:37    ERROR    26113    Create backup via OC    Operations Console administrator “RSAAdmin” attempted to create a backup at “\\sample.com\RSA_Backup\201504151135.RSAbackup”    
Failure Unexcepted exception caught    RSAAdmin    UNEXPECTED_EXCEPTION    testAM81pri.kangnet.local .admin.impl.OCManageBackupImpl$1CreateBackupThread \\sample.com\Share\201504151135.RSAbackup
Cause  - Local Security Policy or Group Policy requires NTLMv2 on the network refusing LM and NTLMv1 (Note: AM8.1 SP1 P1 included NTLMv2 support)
  - DNS resolves the Windows server where hostname is used
  - Directory has correct permissions
Please check first if the Remote location is pinging from appliance. (Operations Console > Administration > Network > Network Tools)

   1. Try mounting the remote share manually, by executing the following commands:


   login as rsaadmin

   sudo su - 

   rsaadmin's password:

   cd /opt/rsa/am/backup/

   mkdir test

   mount.cifs <Remote_Share> /opt/rsa/am/backup/test -o user=<Share_User>,domain=<Name>

   Provide the remote share password when prompted.

   df -h

   Should display mounted partition, try to access the share from appliance


   2. Create a file to validate the user has write permissions:

   echo "test">/opt/rsa/am/backup/test/test.txt

   cat /opt/rsa/am/backup/test/test.txt

   validate test.txt file created in remote share


   3. If above does not work, please try with sec option as below for NTLMv2: 

      a. mount.cifs //sample.com/Share /opt/rsa/am/backup/test -o user=<Share_User>,domain=<Name>,sec=ntlmssp

      b. mount.cifs //sample.com/Share /opt/rsa/am/backup/test -o user=<Share_User>,
domain=<Name>, sec=ntlmsspi