000031384 - RSA Archer packages fail to generate with no reason for failure or zip is empty after download

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support on May 16, 2019
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000031384
Applies ToRSA Product Set: Archer
RSA Product/Service Type: Archer
RSA Version/Condition: 5.x, 6.x
 
IssueIn some version the package fails to generate and in other version the package appears to generate correctly, however when we look at it, the zip is empty. Here is an example of the error from the job engine log:
 

<E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent">
    <System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system">
        <EventID>0</EventID>
        <Type>3</Type>
        <SubType Name="Error">0</SubType>
        <Level>2</Level>
        <TimeCreated SystemTime="2019-05-10T18:25:02.0818878Z" />
        <Source Name="Archer.Kernel.Packaging" />
        <Correlation ActivityID="{03e5aaa4-814f-45c0-8404-1c85b44555db}" />
        <Execution ProcessName="ArcherTech.JobFramework.Job" ProcessID="34544" ThreadID="1" />
        <AssemblyVersion>6.6.0.1369</AssemblyVersion>
        <Channel />
        <Computer>Server2</Computer>
    </System>
    <ApplicationData>
        <TraceData>
            <DataItem>
                <TraceRecord Severity="Error" xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord">
                    <TraceIdentifier>Archer.Kernel.Packaging</TraceIdentifier>
                    <UserId>183</UserId>
                    <Description>Could not find a part of the path 'E:\RSAArcher\Repository\1080.zip'.</Description>
                    <AppDomain>ArcherTech.JobFramework.Job.exe</AppDomain>
                    <Exception>
                        <ExceptionType>System.IO.DirectoryNotFoundException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType>
                        <Message>Could not find a part of the path 'E:\RSAArcher\Repository\1080.zip'.</Message>
                        <Source>mscorlib</Source>
                        <StackTrace>   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
   at ArcherTech.Kernel.Brokers.RepositoryFileBroker.Write(Stream repositoryFileStream, String filename)
   at ArcherTech.Kernel.Brokers.RepositoryFileBroker.WriteFile(RepositoryFile repositoryFile, Stream repositoryFileStream, Boolean runValidations)
   at ArcherTech.Kernel.Jobs.Packaging.GeneratePackageJobHandler.GeneratePackage_ExecuteCode(Object sender, EventArgs e)</StackTrace>
                    </Exception>
                </TraceRecord>
            </DataItem>
        </TraceData>
    </ApplicationData>
</E2ETraceEvent>


 
CauseThis is caused by an incorrect file repository path. The repository path needs to be shared so all servers can reach it. For example: If the repository path is set to a local path such as E:\RSAArcher\Repository but the job engine is running on a different server, it won't be able to reach it.
ResolutionThis solved by having a true shared path in the Archer Control Panel file repository path designation. One way this can be solved is by using an unc path that all servers can access.

\\servername\repositorypath

Attachments

    Outcomes