000031135 - Identity Management and Governance 6.9.1 shows the following error: "The Oracle version 12.1.0.2 is not supported"

Document created by RSA Customer Support Employee on Jun 14, 2016Last modified by RSA Customer Support on Mar 5, 2018
Version 3Show Document
  • View in full screen mode

Article Content

Article Number000031135
Applies ToRSA Product Set: Identity Management and Governance
RSA Product/Service Type: Appliance, User Interface
RSA Version/Condition: 6.9.1
IssueThe incorrect error message occurs in the under Admin > System > Diagnostics under Initialization Warnings:


The Oracle version 12.1.0.2 is not supported



In addition, an incorrect log message at the WARN log level also occurs in the aveksaServer.log during startup.




08/04/2015 20:10:29.685 INFO  (main) [com.aveksa.migration.jdbctool.CheckDatabase] Oracle version:    12.1.0.2
08/04/2015 20:10:29.688 WARN  (main) [com.aveksa.migration.jdbctool.CheckDatabase] The Oracle version 12.1.0.2 is not supported. The supported versions are 11.2.0.2,


 
CauseThe startup code incorrectly flags the version as unsupported for remote databases. 
ResolutionPer the documentation in the RSA Identity Management & Governance 6.9.1 Platform Support MatrixOracle 12c version 12.1.0.2 is supported as a remote database for RSA Identity Management and Governance 6.9.1.   The product incorrectly indicates that 12.1.0.2 is not supported on startup.   This warning message has no functional impact on the product and can be ignored.

This error message will be suppressed in future patches of 6.9.1.

NotesSee 000031110 All reviews fail with ORA-ORA-01792 error when using Oracle 12.1.0.2.0 as an external datastore for some additional notes about using Oracle 12c as a remote datastore.

Attachments

    Outcomes